4

I have the following situation: I am trying to setup an NTP server in LAN, which will update the NTP clients in LAN. All machines are CentOS, and ntpd that is running is ntpd 4.2.6p5@1.2349-o Sat Nov 23 18:20:11 UTC 2013 (1)

I configure the following in ntp.conf:

Server:

server X.X.X.X iburst
server Y.Y.Y.Y iburst
server Z.Z.Z.Z iburst
restrict 192.168.1.0 mask 255.255.255.0 notrap nomodify nopeer noquery
broadcast 192.168.1.255 minpoll 3 maxpoll 4
disable auth

Client:

broadcastclient

Now, I stop both the NTP server and NTP clients, and I set in one of the machines wrong date to verify that the NTP message will fix it. Afterwards I restart both the client and the server. I am able to see NTP broadcast packets leave the NTP server, and arrive to the NTP client (using tcpdump). But date and time are still not updated at the client machine.

What am I doing wrong?

Many thanks for your answers.

A.

  • Show us the output of ntpq -q of the client. – Martin Schröder Jun 25 '14 at 11:46
  • 1
    It outputs "No association IDs returned". – Alex Jun 26 '14 at 10:43
1

Add "disable auth" option to the client configuration too:

Client:

broadcastclient
disable auth

Have in mind, that with the server configuration like yours (that is: without local time source), client will pull the time from the server only when server is synchronised with its peers itself. You can check it with ntpq -p command on the server.

Another catch with broadcast client is that option restrict (server network) nopeer on the client effectively blocks him from synchronisation with unknown (i.e. discovered by listening their broadcasts) peers. But I do not see that option in your client configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.