1

We have a Remote Desktop Services 2012 member server, this was on a Windows 2003 functional level domain and was working well. All RDS roles are on the same single server. Server is not a DC

We upgraded the last domain controller to Windows 2008, all went well

However, our RDS server is now not allowing Remote App Connections, I have tracked this down to a couple of issues which both appear to be linked to the DC functional level raise.

The last issue I can't solve is the following in the event log of the Session Broker

The Remote Desktop Connection Broker server could not enumerate 
the targets for the provider named NULL from the database.

Pooled virtual desktop collection name: NULL
Error: Logon to the database failed.

Searching has lead me to http://www.urtech.ca/2013/02/solved-server-2012-remote-desktop-connection-broker-server-could-not-enumerate-the-targets-for-the-provider-named-null-from-the-database/ which states that "you need to manually add your Remote Desktop server into the MEMBER OF tab of “Windows Authorization Access Group” via Active Directory Users and Computers."

I have tried this, I misread this at first and added the Computer account to the Members tab, this hasn't improved matters, reading the piece again I see that's this states the Broker (I'm assuming the computer, as the Broker Service uses the Network Service) needs to be added to the Member Of

I'm assuming this is a typo as attempting to add this Computer to the Member Of is not possible as the Add and Remove buttons are greyed and a message is showing stating "Builtin groups cannot be added to the other groups."

Any searches on this eventually lead me back to this article or http://support.microsoft.com/kb/331951 which I have read and as a result have added the Computer Account to the Windows Authorization Access group

Has anyone encountered this, or know how I can get the session broker access to the database?

  • 1
    Could you describe what you mean by "RDS server is now not allowing Remote App Connections"? I've found RDS servers to heavily tie into the domain and unfortunately small changes to the domain have forced me to remove and create my Remote App collectinos – R.K Jun 26 '14 at 14:06
  • All the remoteApp client reports is "An error occurred. Contact your workplace administrator".... this lead me to investigate, I've fixed 3 issues that were in the logs, mainly regarding Permissions on accessing log files (change permissions on the folders in system32 \logfiles\SUM) – Great Big Al Jun 26 '14 at 14:21
  • 1
    Did you ever resolve this? I'm having the same issue after upgrading one of my AD servers to 2012 R2. – Chris S Oct 14 '14 at 22:10
  • No, we installed a new virtual win 2008 and used Terminal services on that instead, works as expected – Great Big Al Oct 16 '14 at 5:47
  • Might not be related but make sure to check your ssl cert. We had an issue like this showing exactly same error message resulted from an expired ssl cert. – KuN Feb 17 '17 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.