I am facing strange issue, I am using Centos6. I can connect to ssh but i am unable to connect to SFTP. now the strange part is, if i restart server, SFTP starts working again for few mins, and then again goes time out.

It shows only 1 error, server time out. I tried to even create new user, but not worked.

When it was new server, it was all working fine, this have been happening from last week. I even checked the sshd_config file, the passwordauthentication is enabled, the ssh path on last line is enabled as well.

  • 1
    Anything in the logs at the time of failure-after-reboot?
    – MadHatter
    Jun 27, 2014 at 14:47
  • I am using filezilla & coda, in filezilla it says Error: Connection timed out Error: Could not connect to server
    – niraj
    Jun 27, 2014 at 15:01
  • 1
    Not client-side; server-side.
    – MadHatter
    Jun 27, 2014 at 15:14
  • Its not showing any errors :(
    – niraj
    Jun 27, 2014 at 15:49
  • I am not a pro user, sir but is there any thing like clearing cache?anywhere in ssh? which might be a problem? But SSH is working just fine. server load is 0.25.
    – niraj
    Jun 27, 2014 at 15:54

1 Answer 1


In you client side, try ssh-add command before (one time only) start the sftp session

  • Hi, thanks for reply, but how do i add it in Filezilla & coda?
    – niraj
    Jun 27, 2014 at 14:58
  • if you run $ ssh-add ~/.ssh/id_rsa (change key path) in your client, Filezilla probably work.
    – gpupo
    Jun 27, 2014 at 18:11
  • Important: Filezilla logon type must be "interactive"
    – gpupo
    Jun 27, 2014 at 18:13

Not the answer you're looking for? Browse other questions tagged .