1

I'm trying to run snmptranslate on my system but it does not work, even if I did everything by tutorial from net-snmp.org. They say it should work but it doesn't.

I have a debian 6 server and net-snmp 5.4.3. I tried what they say here, the official tutorial but it still returns same error:

No log handling enabled - turning on stderr logging
MIB search path: 
/home/las/.snmp/mibs:/usr/share/mibs/site:/usr/share/snmp/mibs:/usr/share/mibs/iana:/usr/share/mibs/ietf:/usr/share/$
Cannot find module (SNMPv2-TC): At line 10 in /usr/share/mibs/netsnmp/UCD-DLMOD-MIB
Cannot find module (SNMPv2-SMI): At line 34 in /usr/share/mibs/netsnmp/UCD-SNMP-MIB
Cannot find module (SNMPv2-TC): At line 37 in /usr/share/mibs/netsnmp/UCD-SNMP-MIB
Did not find 'enterprises' in module #-1 (/usr/share/mibs/netsnmp/UCD-SNMP-MIB)
Did not find 'DisplayString' in module #-1 (/usr/share/mibs/netsnmp/UCD-SNMP-MIB)
... and so on

I even created ~/.snmp/mibs directory and put there 2 cisco mibs but after I tried to run snmptranslate, I get the error.

1

I found a solution. I installed this package:

sudo apt-get install snmp-mibs-downloader

After installing, run this command:

download-mibs

It should download all necessary mibs.

  • 1
    It could be necessary to edit /etc/snmp/snmp.conf and comment the line with word mibs. – shadox Jun 30 '14 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.