0

SCENARIO -

DEV: Customer uploads 104KB csv File is uploaded to specified directory then read and populated into data table.

Request Size Limits
Maximum number of POST request parameters   100
Maximum size of post data   20MB 
Request Throttle Threshold  4MB 
Request Throttle Memory   200MB 

DEV is a single server.

QA: Customer uploads 104KB csv File is uploaded to specified directory but not read into table

Request Size Limits
Maximum number of POST request parameters   100
Maximum size of post data   20MB 
Request Throttle Threshold  4MB 
Request Throttle Memory   200MB 

NARRATIVE -

QA is load balanced between two servers via F5 device with cookie-enabled session persistence. Both servers are configured via CF10 Enterprise sandbox to access same data area. Code is promotion is automated up the server stack from DEV to QA to PROD. Code functions as expected in DEV, but not in QA which leads me to suspect a server configuration difference or a load balancing session issue. I have verified the request size limits match in the single server DEV environment and the dual server QA environment.

Modifying QA to:

Request Size Limits
Maximum number of POST request parameters   100
Maximum size of post data   100MB 
Request Throttle Threshold  100MB 
Request Throttle Memory   500MB 

does nothing for the process and the browser still times out. I do not see anything logged in the CF admin indicating the failure nor anything in the IIS logs indicating the failure. What could I be overlooking? Thanks in advance.

0

There is a limiter in CF and also in IIS/Apache check your webservers upload limit and change that too. You can create an override via your config file e.g. web.config. Also increase you CF timeout in your application (for good measure ...if you deal with larger files).

  • Thank you. I increased the connection time-out in IIS to 500 seconds. The developer has a cfsetting requestTimeout set to 10000 in application.cfm. There is no web.config to use. Unfortunately, the page still errors. Should the IIS connection time-out match the application.cfm requestTimeout? – aparker81 Jun 30 '14 at 17:37
  • In the management console window thing there should be a seeting there you can change: look for something like "Edit Feature Settings" for teh website your are working with. Then modify "Maximum allowed content length". In might vary with your IIS flavor but you can do that in the control panel administrative tools IIS admin tool. also here is a link that might help. mywindowshosting.com/support/KB/a1544/… – Frank Tudor Jun 30 '14 at 18:39
  • It appears that the "Maximum allowed content length" on both servers, running IIS 7.5 is set to 30000000 bytes which seems it would be sufficient. – aparker81 Jun 30 '14 at 20:47
0

Coldfusion has a setting buried in the neo-runtime.xml called postParametersLimit. It's set to 100 by default - meaning you can't post more than 100 params to a cfm page. You can set this number higher to get past the error you are seeing. Check out Cutter's blog for more details on where that file is located and how to fix this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.