1

I recently acquired a red hat server that runs RHEL 5.5. I get a feeling that my YUM repositories are totally out of date because of the following reasons:

  1. I tried updating GCC using YUM. The updated version shows 4.1.2-54 as the version number, while the latest is 4.9.
  2. Similarly, I tried installing SVN. The (newly) installed version shows 1.6.11 as version number, while I believe 1.8.9 is the latest.

Because of these incidents, I am led to believe that my YUM repositories are out of date. Further, all these happened after I updated the system using 'yum update'. Is there anything I can do to update the repository URLs without upgrading RHEL to a newer version? Thanks a lot!

  • You don't. Why do you want more recent versions? – Michael Hampton Jun 30 '14 at 21:40
  • you can build these packages from src rpm:s (and dependencies) and install them alongside with your other versions, however since RHEL 5 first released 7yrs ago, you should check if you could instead aquire a RHEL6 box in stead (or even RHEL7). – Petter H Jun 30 '14 at 21:53
  • I had to install a few quantum chemistry packages that require SVN(1.7+), cmake (2.8+) gcc (4.6+) and intel compilers (13.0+). Obviously I can compile them all from the source (which is what I finally had to do), but I was curious as to why YUM didn't work. Thanks, everyone! – Pradeep Jul 1 '14 at 22:57
3

They are not out of date. Enterprise Linux (RHEL/CentOS/Scientific Linux) maintain a repository of software with a stable feature set, API and ABI. It is intentional that the versions of software being used on this host are what they are.

Only bug fixes typically get applied to such software. The intention is that the distro major version (so 5 in this case) is as consistent as when it was at first release, and more stable with each point release.

In a production environment, it is more important that the platform presents a consistent interface.

If you want to develop on something more 'bleeding edge' Fedora is typically the choice for Redhat derived systems.

Note, Fedora is not considered stable or consistent and is not suitable for production.

If you are looking for something more up to date but stable, RHEL7 was (at the time of writing this answer) released quite recently. That is based mostly off of Fedora 19.

Do not expect to be able to update the operating system from CentOS 5 to RHEL 7 merely by using the yum repositories as you will seriously break the system. Instead you would be required to reinstall the host to that version instead.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.