0

We are having issues with an ADFS environment (providing authentication for a Dynamics CRM 2011 IFD installation), symptoms are as follows:

  • We navigate to https://crm.domain.com:444
  • We see the ADFS authentication form
  • We enter valid credentials
  • We are redirected to the authentication URL
  • Instead of being redirected to the site, a Windows auth popup shows up, requesting credentials, stating "The server https://auth.domain.com requires a username and password" [auth.domain.com is the ADFS server]
  • Any credentials we input in the popup leads to some waiting, and the popup shows up again
  • If we navigate away and go back to https://crm.domain.com:444 we are not asked again to authenticate but the popup shows up immediately (so it seems ADFS authentication has indeed worked).

We already tried to reboot all servers:

  • DC first
  • DB second
  • ADFS/CRM last

Customer's IT person is at a loss too (he's new to ADFS, and we are devs not IT people ourselves so out knowledge is hit and miss). Is there any known solution ?

I'll add more info/specs as needed (I'm not sure what's relevant).

1

I suspect the authentication settings on the virtual directories have been messed about with.

Ensure /adfs virtual directory is set to anonymous only

Ensure /adfs/ls is set to anonymous and Windows Integrated Auth both only.

  • I forgot to follow up on this: authentication settings were indeed off, after fixing them like you suggested everything went back up. Further investigation revealed that a third party was working on some kind of unrelated web app, and was oblivious about the ADFS having stopped working ... – Alex Mar 12 '15 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.