1

I'm in the process of upgrading our Windows 2012 Hyper-V hosts to 2012R2. As part of this process, I am migrating existing VMs from the 2012 hosts to hosts that have already been rebuilt. These are shared-nothing migrations; we don't have a SAN (yet).

Several of these VMs are Windows 7 Pro 32-bit. They seemed to survive the migration OK, however due to a network misconfiguration elsewhere (they were given static IPs that were still being handed out by DHCP) two of them lost their connections. While troubleshooting this problem and before I tracked it down, I tried upgrading the Integration Services software on the VMs. I think this is the source of my trouble.

Now their network connections are VERY spotty. Sometimes pings will work in both directions, sometimes they work in one direction, sometimes they work in neither direction. Same goes for network connectivity in general.

Things I have tried:

  • Turning firewall off
  • Connecting to a different virtual switch
  • Deleting and re-adding the NIC in the guest OS
  • Deleting and re-adding the NIC in the Hyper-V settings for the guest
  • Replacing the standard Virtual NIC with a Legacy Virtual NIC
  • Moving the guest to a different host altogether

I'm not seeing anything in Event Viewer, no stopped or failed services.

The only difference in the two problematic VMs from the other five (which appear to be working fine, knock on wood) is that I upgraded the Integration Services package on the two bad ones, and not on the others. Also, it only seems to be the Win7 VMs affected by this; I've upgraded Integration Services on several Server VMs and they appear to be working properly.

I'm stumped and frustrated. Any ideas?!

Thanks!

1

That's pretty puzzling, but it sounds like you've taken a good few first steps.

I would suggest two things:

1 - Ensure that you have the latest integration tools on your hyper-v host (Windows updates should get that for you) - you'll need to reinstall the new version on any guest machines.

2 - Use Ghostbuster (http://ghostbuster.codeplex.com) to remove any old networking hardware that is still installed on the Windows VMs. This sounds like a driver problem if everything else matches between the working and non-working VMs.

  • Thanks for the reply. As I mentioned, installing the newest version of the integration tools is, I believe, what broke it! I also just went back and enabled device manager to show nonexistent hardware and removed the old NICs, then uninstalled all networking "hardware" both in the guest OS and Hyper-V, readded it all, and still no dice! – Rob_C Jul 2 '14 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.