0

I have just set up a Cygwin SSH server and successfully tunneled to it from a remote location. Logging in works but when I point my browser to localhost 8888 (sock 5), all connections are refused.

How is it that I can log in, then not browse from a remote location? Could it be to do with port forwarding on my router? (currently have 22 forwarded to the SSH server machine).

Other info...

  • I can SSH into the server on the local machine and successfully browse.
  • I am connecting remotely with ssh -D 8888 mysite@test.mysite.net -vv
  • Server is Windows and client is OSX (terminal)

Edit: Frustratingly, without knowingly changing anything on the server local tunnel proxying has stopped working. Both clients now connect and accept the password before debug1: Exit status 1

  • Just to be clear, you're running ssh on the OSX host, and you're also running the browser on the OSX host? – Kenster Jul 3 '14 at 18:27
0

What OS is the client you are using?
Is the ssh client staying open while you are trying to connect with your browser?
If you are using the openssh client to create this tunnel, you may want to add in a -N flag to create the tunnel without requiring a command:

ssh -ND 8888 mysite@test.mysite.net -vv

You may also want to check the output of netstat after creating the tunnel, just to make sure that it is actually live.

| improve this answer | |
  • Thanks for the quick response:) I'm using terminal in OSX to tunnel and Cygwin on Windows as the server, and yes it's staying open when I attempt to configure Firefox. The I'll try your suggestion anyway. – square_eyes Jul 3 '14 at 16:27
  • For that I get Bad dynamic forwarding specification N – square_eyes Jul 3 '14 at 16:30
  • Also see my edit above:/ – square_eyes Jul 3 '14 at 16:48
  • Sorry, I just edited my post. N should come before D. On your OSX machine, can you see the tunnel in netstat -l after you open it? – Unix-Ninja Jul 3 '14 at 18:41
  • OK that worked. My first tunnel:) It's extremely slow though. I don't expect to be quick as the client is in Asia and server in Australia. But even logging in took several minutes, where yesterday (without -D) it was logging in quickly. By that I mean, I would get a string of lines (verbose logging) pour down the client. And it would get to the password request in seconds. Then it would accept my password quickly also. Now it crawls along. Would I need to restart the Cygwin server? – square_eyes Jul 4 '14 at 2:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.