0

I try to copy files to a remote server (OSXServer) using scp. I have 2 user accounts on that server with what I thought the exact same settings. Now I tried the copying files into the respective home folder (every user has one home folder) on the server. This works for one account but not the other. How can I find out why this is happening and maybe change the settings so that I can copy stuff with both accounts?(I have administrative access with both accounts according to the workgroup manager)

Edit:

It is a pure permission problem as "touch" does not work either with the one user account.

Edit2:

chown -R "usrname" "folder"

also gives me permission denied.

Edit3: To top the weirdness: Everywhere else except of the home directory it works fine...

Edit4: I have no idea why the server was set up in such way but now I could change the permissions logging in as root...

  • What are the permissions on the non-working users' home folder? (check with ls -ld ~username) – mtak Jul 1 '14 at 14:28
  • "nobody" how can I change that? Basically every new user I create has "nobody" in his home directory. – user3683367 Jul 1 '14 at 14:34
  • "nobody" refers to ownerships. @mtak was asking about permissions (i.e. read, write, and execute bits). Can you please provide the output to the command he specified? – Paul Calabro Jan 10 '17 at 5:10
-1

Log in using your super user and set work location to your other account and give some group permission to your weird account.

| improve this answer | |
  • 1
    That's just masking the actual problem, not fixing it. The real problem is getting the correct owner settings on the other account. – Magellan Jul 4 '14 at 21:42
  • The other account is nobody bro, to fix it you can use other super user to set up the correct owner to the othr account. – Eko Junaidi Salam Jul 9 '14 at 3:53
  • That's what I said. Adding group permissions is not correct. – Magellan Jul 9 '14 at 16:08
  • May be adding group permission is not correct. So, do you have any better idea how to solve that ? – Eko Junaidi Salam Jul 9 '14 at 16:24
  • What I said in the first comment. Go read it. – Magellan Jul 11 '14 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.