0

So I realize my title is almost laughable, but my situation is this. I have a fairly complicated desktop app written in Python and the PySide Qt bindings and I need to make a stripped down version of it that can run online. My basic procedure is to remove the QtGui elements and replace them with Javascript and canvases, and then link javascript functions to the underlying QT code (via Django views) which takes advantage of QT signals and slots and various other features.

Now, I have this running successfully on a local Django development server, but I'm having trouble moving it online. I'm using elastic beanstalk at the moment and I followed this tutorial to get the django portion of the site up and running. PySide however is proving to be an issue. I've tried the following:

-Tell Amazon to run pip install PySide when instantiating the environment - this doesn't work for unknown reasons, I just get a server error

-Store the /site-packages/PySide files in an S3 bucket and copy them into the amazon virtual environment - this crashes telling me it can't find certain .so libraries even though I have verified they are in the LD_LIBRARY_PATH

I'd appreciate any help or guidance in getting this up and running. I don't have a lot of experience using Amazon web services.

Thanks

  • "this doesn't work for unknown reasons, I just get a server error" And that error is... – ceejayoz Jul 4 '14 at 20:50
  • Sorry, I wasn't clear enough. I mean the webserver just says "Error 500", if there is a place to get specific information on it, I'm not sure where. – The Bearded Templar Jul 4 '14 at 20:53
  • 1
    It will be in your logs, of course. – Michael Hampton Jul 4 '14 at 20:54
  • I just tried again as it was a few days ago when I initially tried using pip install PySide. This time I installed PySide on my local server, and updated my requirements to text to include it. When I tried to rebuild my amazon environment I got this: Stack named 'awseb-e-3pz63i3ei6-stack' aborted operation. Current state: 'CREATE_FAILED' Reason: The following resource(s) failed to create: [AWSEBInstanceLaunchWaitCondition]. (Service: AmazonCloudFormation; Status Code: 400; Error Code: OperationError; Request ID: null) – The Bearded Templar Jul 4 '14 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.