0

I have an email server Postfix (not open relay) filtered with ASSP (filter incoming mail/connection), but some spammer is sending tons of spam using my email server by using fake local address.

This fake local address makes it seems that the email come from users of my email server.

He can't use his (from) email address, I already put some filter (multiple instance postfix).

The fact that he send the email using fake local address (randomly generated), makes it hard to fight.

I've fix (but not totally) the problem using postfix check_sender_access (list all local sender), but seems not that effective.

  • 5
    Why are you allowing external hosts to relay without authentication? Turn on authentication and your issue will go away. – EEAA Jul 5 '14 at 16:15
2

You must setup specific hosts that can relay mails to your postfix server. That way, you can define the only servers that can relay mails to you. Also, turn on spf (sender protection framework) so that when a mail comes in and is not coming from an authorized server, it will be rejected.

| improve this answer | |
  • I think it is not relaying.. he connect directly to my smtp server with SMTP request, to my ASSP SMTP Proxy.. and send email behalf of fake local address.. or is it relaying? CMIIW – ojak Jul 6 '14 at 8:31
  • 3
    @ojak, YES, that action is relaying. Looks like your postfix is misconfigured. For further help, please edit above question and post the output of command postconf -n – masegaloeh Jul 7 '14 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.