0

I've created a new directory in /var/ftp with the name uploads

the owner and group of this directory is ftp

the permissions are set to 777.

Content of my vsftpd.conf file

anonymous_enable=YES

local_enable=YES

write_enable=YES

local_umask=022

anon_upload_enable=YES

anon_mkdir_write_enable=YES

xferlog_enable=YES

xferlog_file=/var/log/xferlog

xferlog_std_format=YES

nopriv_user=ftpsecure

ascii_upload_enable=YES
ascii_download_enable=YES

listen=YES

pam_service_name=vsftpd
userlist_enable=YES
tcp_wrappers=YES

SELINUX permissions are -

allow_ftpd_anon_write --> on
allow_ftpd_full_access --> on

I can upload files in directory but can't delete files through FTP

Can anyone suggest me what to do?

  • I've created a user and have tried to delete files through that too. I can easily connect to ftp but I'm unable to delete files – Kunal Jul 7 '14 at 14:04
1

Take a look at the manpage of vsftpd and use the option: anon_other_write_enable=YES

  • I have disabled SElinux. Still I can't delete files :( – Kunal Jul 23 '14 at 11:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.