0

I have to get virtual machines replicating across the internet, from a Hyper-V Core 2012 R2 machine on one domain (lets call this Primary.Domain1.local) to our replica machine here (Lets call this Replica.Domain2.local)

We have set up a VPN between the two locations - which may or may not be necessary as I understand it. Anyway, I can ping my replication machine from the primary hyper-v host, so that should be okay. I have enabled all the relevant firewall rules on both servers, my https hyper-v reciever is running, and I created a self-signed root CA on each machine, with private key certificates generated under each CA on each machine. I then took both of these certs and imported into the other server on each end. I configured Replica.domain2.local's listener to use it's Replica.domain2.local certificate, as well as the opposite for the Primary server when setting up replication.

It seems that I may be missing some firewall rule for another management service or something along those lines. When I go to turn on replication, my first red flag is on the wizard where it says "Could not get configuration details of the specified server."

  • Wow, are you sure that is even possible? – Zoredache Jul 7 '14 at 21:23
  • Pretty interesting, I think you should looks through the logs on either server to find out what's the actual error message and if there's any fix around. I found the following article that might assist you with what you're seeking to achieve. blog.powerbiz.net.au/hyperv/… – Vick Vega Jan 22 '15 at 19:01
0

HyperV Replication occurs via HTTPS. You should confirm that both machines can reach each port 443 on the other host.

If you can't, then adjust your windows advanced firewall. See step 1.3 especially here: https://technet.microsoft.com/en-us/library/jj134153.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.