I was using Freenas 8.2 and decided to upgrade to 9.2. All seem to go well, upgraded zfs to 28 and rebooted. During next boot it seem to take forever and at some point I decided to turn off the machine. I guess this is what caused the problem.

When I try to import I get the following:

[root@freenas] ~# zpool import   
pool: vol4disks8tb
     id: 12210439070254239230
  state: FAULTED
 status: The pool was last accessed by another system.
 action: The pool cannot be imported due to damaged devices or data.
        The pool may be active on another system, but can be imported using
        the '-f' flag.
   see: http://illumos.org/msg/ZFS-8000-EY

        vol4disks8tb                                    FAULTED  corrupted data
          raidz2-0                                      ONLINE
            gptid/3d316d16-f53e-11e1-9da5-080027dfca8a  ONLINE
            gptid/3df02143-f53e-11e1-9da5-080027dfca8a  ONLINE
            gptid/3eb99e55-f53e-11e1-9da5-080027dfca8a  ONLINE
            gptid/3f91c723-f53e-11e1-9da5-080027dfca8a  ONLINE
[root@freenas] ~#

EDIT: The commands "zpool import -f", "zpool import -f -F -n" and "zpool import -f -F" return the exact same output as the previous command.

EDIT #2: the command "zpool import -f 12210439070254239230" returned

cannot import 'vol4disks8tb': I/O error
     Destroy and re-create the pool from
     a backup source.

I have so far tried the suggestions found in this answer and the "auto import volume" found in the web interface of freenas which writes this errors in /var/log/messages:

Jul  8 14:46:06 freenas manage.py: [middleware.notifier:3291] Importing vol4disks8tb [12210439070254239230] failed with: cannot import 'vol4disks8tb': I/O error
Jul  8 14:46:06 freenas manage.py: [middleware.exceptions:38] [MiddlewareError: The volume "vol4disks8tb" failed to import, for futher details check pool status]

Running "zpool status" returns "no pools available".

I don't care about most of the data on those disks, however I have close to 15 years of photos on those disks, is there any way to retrieve them? Please help!

  • I see a lot of problems like this with FreeNAS specifically, but not other ZFS solutions. What type of hardware are you using? – ewwhite Jul 8 '14 at 12:24
  • It's an HP microserver with 4 disks added, upgraded to 16GB ram – Uphill_ What '1 Jul 8 '14 at 12:44
  • I'd do it on latest code, but if you have v28 you may have some version of this -- try zpool import -fFX vol4disks8tb – Nex7 Jul 8 '14 at 18:20
  • Oh and to answer your question, yes. It is extremely likely ALL or nearly all of your data is intact, it is merely a matter of getting around the various potential gotchya's that are preventing the normal method of import from working. – Nex7 Jul 8 '14 at 18:29
  • 2
    I suggest zpool import -fFX simply because you've /already/ done -fFn. It might be "safer" to start playing with zdb to determine what, if anything, is wrong with the pool that would kill a normal import. Sometimes this is something silly like missing disk labels (zdb -l <disk> on each disk should help you see if all 4 labels are intact on each disk and are identical). – Nex7 Jul 8 '14 at 18:31

at first see what displays

zfs status

maybe pool is imported now and is 'busy' for another import. if yes, repair pool. if not, follow all bottom.

I found here some doc: http://docs.oracle.com/cd/E19253-01/819-5461/gbctt/index.html you should import damaged pool with autorepair at first make binary copy anywhere. buy some drive for future backups. the import following above doc:

zpool import -F vol4disks8tb

you should get message with I/O error, but info described lost last writed data. you must agree for recovery.

If it doesn't work, unfortunately you lost it all.

I found your last chance. Look at the page, there is described bug with your freenas. http://forums.freenas.org/index.php?threads/zfs-pool-import-corrupted-data.7804/

| improve this answer | |

First of all, make byte-level copies of those disks.

Then kick yourself for not having offsite backups.

Have you tried the zpool import -f command as recommended by your system?

| improve this answer | |
  • Yes, I tried "zpool import -f" and also "zpool import -f -F". This was suppose to be my backup machine – Uphill_ What '1 Jul 8 '14 at 12:17
  • Please put the actual commands and output into your question. – MikeyB Jul 8 '14 at 12:19
  • OK, added the commands as an edit. It's the same output as before. – Uphill_ What '1 Jul 8 '14 at 12:41
  • Tried the numeric ID? – MikeyB Jul 8 '14 at 12:49
  • I tried it now, I'll update the question – Uphill_ What '1 Jul 8 '14 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.