There are four of these files, in three directories. The files cannot be read, deleted, moved, or renamed. I have tried the Explorer permissions dialog, ICACLS, TAKEOWN, and SUBINACL -- all say permission denied. I am logged in as a member of Administrators. Running elevated does not help. Running as %COMPUTERNAME%\Administrator does not help.

The files are not open by any process, either local or remote.

Other files in these folders are perfectly readable, modifiable, deletable.

I even tried running CMD.exe as LocalSystem -- still couldn't access the files.

Since this is a live storage server, it will be some time before I can run a CHKDSK/F. Are there any other tools that might have luck with the files?

OS: Windows Server 2008 R2

Server is a domain member

  • 5
    Typically this is a sign of filesystem inconsistency. You're likely going to be stuck running chkdsk. Are you picking up any NTFS errors in your System Event Log? – Evan Anderson Jul 8 '14 at 16:50
  • Nope. (The comment I entered earlier, and deleted, saying that there were such errors, was about a different server.) – Ross Presser Jul 8 '14 at 17:05
  • Do you get any type of message when trying to manipulate these files? – joeqwerty Jul 8 '14 at 17:38
  • "Access is denied." when trying to type, del, move or ren. Similar messages from ICACLS, TAKEOWN, SUBINACL. – Ross Presser Jul 8 '14 at 17:42
  • I worked around this for IIS purposes using (several) virtual directories... Will try CHKDSK /F on the weekend. – Ross Presser Jul 8 '14 at 18:54

Almost certainly a problem with the NTFS master file table. Seen this very thing myself. Reboot with CHKDSK flagged.

  • Well, instead of rebooting with chkdsk, I force-dismounted it (it was drive D, not C) and ran CHKDSK /F from user mode. It didn't help; after 45 minutes it still had not completed, and I had to abort because my time window was closing. – Ross Presser Jul 29 '14 at 23:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.