6

I'm installing CentOS 7 as virtual machine but I'm having some problems related to network. As image shows I select Minimal Install for later add trough YUM any packages I want as for example: PHP, Nginx, MySQL and so on since this will be a web development enviroment. After the installation, and having the network configured on Vmware Workstation as second image shows, when I logging I can't start network also I can't access to setup or something else, so, what I'm missing? Which version of all is the right to install? And of course the most clean installation without extras

enter image description here enter image description here

Figured out how to get network up, now can't install any groups

Finally and after take a closer look at /etc/sysconfig/networks-scripts I found that my network isn't called eth0 as always instead CentOS generate a ugly name, in this case how I can change that name for eth0?

Now as second point I tried this commands:

yum groupinstall "System Management"
yum groupinstall "System Administration Tools"

And in both cases I get this message:

Warning: Group system-management/system-administration-tools does not have any packages to install Maybe run: yum groups mark install (see man yum) No packages in any requested group available for install or update

And I get lost since I'm trying to install tools like setup and so others, what I miss on this? Is the command right? Do I need to enable something in somewhere?

closed as off-topic by Ward, Jenny D, HBruijn, mdpc, Cristian Ciupitu Jul 10 '14 at 21:09

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – mdpc, Cristian Ciupitu
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What do you mean by "can't access to setup or something else"? What have you tried so far? – Abhijeet Kasurde Jul 9 '14 at 5:13
  • @AbhijeetKasurde I mean when I type setup on console OS said program not found also if I try something like ifup eth0 I get no script configuration for network so I think I miss something during installation or minimal is just minimal and I need to add a lot of things, in that case to get the most complete but also clean installation what option I should pick? – ReynierPM Jul 9 '14 at 5:17
  • @AbhijeetKasurde since this will be a development server I wouldn't need any GUI since I like command line and by clean I mean just the necessary for connect trough network from host (Windows in my case) and them start configuring all that I need like Web Development tools – ReynierPM Jul 9 '14 at 5:19
  • Can you paste ifconfig -a and availability of networking scripts in /etc/sysconfig/network-scripts ? – Abhijeet Kasurde Jul 9 '14 at 5:27
  • 1
    Try /sbin/ifconfig -a, just to be sure. But you may be right, they may have finally retired the ifconfig command in favour of the more monolithic ip (grumble). – MadHatter Jul 9 '14 at 6:07
18

You can use

nmcli & nmtui

If you are using "minimal installation" then all other rpm for web development you need to install separately.

For status of your nic /ip as follow

ip a sh

This is how all servers should be setup. Absolutely bare bones and then add only the services/applications that define its role.

  • Can you take a look to my latest edition? I figured out the network part but I'm still having problems with others – ReynierPM Jul 9 '14 at 6:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.