Using MDT and WDS for deployment I setup a Vista system where I have 3 partitions. One partition is the OS, one is a factory recovery partition with winRE on it and the last is a linux system with a hardware test for the system. Only the OS is visible to the user. The factory recovery disk is accessed by "advanced boot options" for vista and the test partition is accessed by multiboot using Windows boot loader.

My problem is that when I use multiboot I can't access the "advanced boot options". What I tried is both hitting f8 before the boot loader displays the boot options, and right after I've chosen the windows boot option.

If I turn off multiboot I can access the "advanced boot options" and the "factory recovery partition" by pressing f8 during startup. If I turn on multiboot I can boot the linux partition but I can not access the "advanced boot options" to access my "factory recovery partition".

How am I supposed to access the "advanced boot options" so that I can make a factory restore?

Thanks for any help



bcdedit.exe most likely, or this MS link

  • I've added both options with bcdedit and even after the linux boot option is added I have correct values for recoverysequence and recoveryenabled which indicates that it should work. I did not find anything useful in the second link, please be more specific if you see something there. Thanks for your fast answer/ Ola – Ola Sep 1 '09 at 14:40

Have you tried hitting F8 while you're still on the boot entry selection menu screen (while the "correct entry" is selected)?

[I believe you can force the boot menu screen to show (even with a timeout of zero) by repeatedly hitting the space bar while the system is booting. (You might need to wait until just after BIOS is done initializing the system, though.)]

...but you should be able to hit F8 (if you time it correctly) even if the boot menu is not displayed.

  • The thing is that I want the timeout in bcdedit set to 0 so that the end user never sees that it has multiple boot options. Maybe this is not possible so I have to find another way to boot. Do you know if it's only during the time the boot menu is shown you have the option of pressing f8 to access advanced boot options? – Ola Sep 9 '09 at 12:48
  • Thank you for your answer, I managed to get the menu to show by pressing f8 during startup with timeout set to 0, but it only works about 1 of 20 tries. As the units go to customers I need something more reliable. I will try the space bar function to see if the works better. – Ola Sep 14 '09 at 8:09

After a lot of trial and error I concluded that it was not possible to access the advanced boot menu if you have a dual boot setup with a timeout of 0. Atleast not reliably. So instead I did not add one of the options to the view and instead added a custom launch to that boot option.

See more in question Custom launch mechanism (e.g F10) on Vista

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.