2

I inherited a FreeNAS installation that I recently upgraded to version 9. I have some ZFS mounts that are mounted like this:

data1/data on /mnt/data1/data (zfs, NFS exported, local, nfsv4acls)
data1/lan on /mnt/data1/lan (zfs, NFS exported, local, nfsv4acls)

and I am having some permissions problems. I think it has to do with the ACLs, but I am not quite sure. How can I completely disable the ACLs and fallback to the standard Unix style permissions (which are perfectly suitable for my setup) ?

2

As far as I remember it is not possible to disable the ACL on ZFS. But you can try to remove any ACL config with chmod A- filename "Removing all non-trivial ACEs from a file" Take a look at the ZFS ACL admin guide it's for Solaris but I guess that the ACL setup is the same.

| improve this answer | |
  • Thanks. I fixed my direct problems by mounting the drives as CIFS instead of NFS (only NFS mounts had problems). I guess I have some studying to do in the weekend ;). – Bart Friederichs Jul 9 '14 at 8:49
2

setfacl -b removes an acl entry. You can use also use the -R flag for recursion.

| improve this answer | |
  • 2
    Wouldn't it be better to mount the file systems without the nfsv4acls option, so the ACLs stay in place but don't get used, instead of deleting them? – Andrew Schulman Dec 4 '14 at 1:00
  • @AndrewSchulman is it? I like your thinking, but I really am super paranoid about my system as it's in production and I'd like to do the right thing the first time :/ – Florian Sesser Jul 30 '18 at 18:30
0

Best to remove the ACLS with setfacl -bn, they cause nothing but trouble on NFS shares, and are simply a solution looking for a problem.

Shares without ACLS also have a higher data throughput via the shorter code path, than those with.

| improve this answer | |
  • AFAIR setfacl should not work on the newer NFSv4 ACLs anymore (at least that is the case in illumos), you must use chmod instead (not the GNU version, if that should be installed). – user121391 Jul 3 '17 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.