0

I woke up this morning to find my VPS down. I brought it back, couldnt find any reason for it being down (nothing in the syslog, etc) so figured it was my crappy provider. I ran apt-get upgrade and it told me:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

So I ran dpkg --configure -a, it tells me it's updating libdbus:

Setting up libdbus-1-3:i386 (1.6.12-0ubuntu10.1) ...

then the ssh connection closes and the VPS control panel says that the server is down. I can boot it through their control panel, but I can't use apt until this gets resolved. I have no idea how to proceed.

EDIT: Should mention this is an OpenVZ VPS

  • It's your crappy provider. No properly set up OpenVZ host should act in this manner. – Michael Hampton Jul 23 '14 at 4:53
0

Take a look at: https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/740390

You can try to reproduce it using those steps, that problem sounds similar to yours, I've never encoutered it but could be what you're looking for.

If your provider gives you console access to your VPS, console to it and do the test.

| improve this answer | |
  • I looked at that, it came up when searching. It's an issue about unclean shutdowns when shutdowns are supposed to happen, not when performing the upgrade – Finn Jul 9 '14 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.