Laptop: HP HDX X16T-1200 CTO Drivers: Taken from the HP Site and extracted.

Imported in to MDT 2013. When I launch the Lite Touch it pops up an image saying it can not find the ImageDeploymentShare via DHCP so it looks like even with the network drivers injected I still get nothing.

ipconfig /all shows nothing.

Is this a driver or PE issue? I did research and I know this system works with Windows 8 and the drivers. But for some reason the network does not seem to work from PE.

EDIT: I have now found other drivers recently for Windows 8. I still can not get MDT to get past the DHCP issue. IPConfig still shows no network settings.

enter image description here enter image description here enter image description here

  • Please confirm that you are using a freshly created ISO after you completely regenerated the boot image. Do you have a selection profile selected for your boot image that includes the new drivers?
    – Bin
    Jul 10, 2014 at 17:40
  • Yep, I added the drivers and even have them included. I'll add pictures
    – Jason
    Jul 10, 2014 at 18:18
  • Your images look good. They recommend trying to inject the minimum set of drivers into the WinPE to reduce the amount of data that needs to be tftp'd, but for troubleshooting, "all drivers and packages" is aok.
    – iPaulo
    Jul 11, 2014 at 17:12
  • Instead of trying to use HP's drivers try driverpacks.net. Their drier packages work on MOST (never seen any that does not work) hardware. Jul 12, 2014 at 12:23

2 Answers 2


Are you using Windows Deployment Services (WDS) to boot via PXE?

Assuming you are, when you "imported in to MDT", did you also update the deployment share and add the updated WinPE boot image (x86 or x64, or both) to WDS?

The boot images are located in "\NAME\DeploymentShare$\Boot". Add them using the WDS MMC (below).

Add Boot Image in WDS mmc

The screenshot also shows multiple versions of boot images taken from deployment shares after they were added to WDS.

Sounds like you are deploying Windows 8, so this doesn't matter, but for others who may come along, MDT 2013 uses WinPE 5.0 so you need to inject Windows 8 drivers into the WinPE boot images even if deploying Windows 7.

references: http://www.deploymentresearch.com/Research/tabid/62/EntryId/112/MDT-2013-Lite-Touch-Driver-Management.aspx

Related Serverfault question - see part 2 of the question/answer

  • 1
    I believe that I imported directly from an extracted .ISO file so I never touched or use WDS but I do have WDS running on the network. I did do a full update on the deployment share for MDT
    – Jason
    Jul 10, 2014 at 0:11
  • I can't profess to be an expert, so your configuration could be different. But at least in our rather default setup of MDT 2013, the process depends on WDS. It would have been installed by MDT. The default WinPE boot iso included with WDS will boot most systems so you haven't need to be aware of the WDS dependency. After updating the deployment share, update the WDS WinPE images with those found in the MDT deployment share.
    – iPaulo
    Jul 11, 2014 at 16:51
  • To verify, do you have an older system available that does boot into WinPE successfully & does get a dhcp address? If so, shut down WDS on your MDT server and try to boot that system. It should fail.
    – iPaulo
    Jul 11, 2014 at 17:00

First: Injecting the drivers is not for Windows PE. Driver injection is for OS Deployment so that the host OS (the one that is being installed) will have use of its hardware.

Second: Driver injection works if you have a network connection (which you don't from what you have posted.

Here is what I do (which should help): I downloaded all related (W7 x86 for me) Driver Packs from driverpacks.net and added them into their own categories E.G. Audio, Chipset, WLAN etc...

I then made a special selection profile for my networking drivers and had the Deployment Share PE build properties point to it.

I rebuilt the images and it worked for me!

I use WDS. To get the boot images I navigate to the deployment share's boot folder and use the wim images in there for WDS. I do not extract the ISOs (from what I read they have extra files for standalone operations.)

Hope this helps :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .