0

I have net-snmp 5.5 installed. But the application I'm trying to install depend on net-snmp-agent-libs. I can find it anywhere. The application instruction says if I compile net-snmp from source I shouldn't have a dependency problem.

I tried to compile net-snmp from source but it didn't solve this problem.

Where can I find net-snmp-agent-libs rpm that is of the same version as my net-snmp (5.5)?

6
  • 1
    Exactly what are you trying to install? – Michael Hampton Jul 10 '14 at 2:47
  • @MichaelHampton, kamailio-snmpstats – Allen Zhang Jul 10 '14 at 2:53
  • And where did you get it from? – Michael Hampton Jul 10 '14 at 3:04
  • @MichaelHampton, rpmbuild from modified source code. They aren't from the kamailio's build service. – Allen Zhang Jul 10 '14 at 3:13
  • You probably started with the wrong spec file, then. That package is in Fedora and EL 7, but not in EL 6. – Michael Hampton Jul 10 '14 at 3:13
0

Problem solved.
In case someone wants to know: There is a bug in the spec file I was using.
As MichaelHampton pointed out in the comments, net-snmp-agent-libs is a fedora package. There is no such rpm in centos repository.

The bug in the spec file is this :

%if 0%{?centos}
Requires:      net-snmp-agent-libs
%else
Requires:      net-snmp-libs

where centos should be fedora .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.