0

I am configuring Oracle 9i to make use of AWE memory configuration on Windows 32-bit.

I am facing error ORA-27102: out of memory OSD-00022: Message 22 not found; product=RDBMS; facility=SOSD

Additional Details OS: Windows 2003 Server Enterprise Edition 32 BIT Oracle: Oracle 9.2.0.1.0 Enterprise Edition

  • Server CPU Count: 16
  • Server Ram: 32GB

Boot.ini

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003, Enterprise" /noexecute=optout /fastdetect /PAE

Registry

AWE_WINDOW_MEMORY: 1384120320

Oracle Settings

  • *.aq_tm_processes=1
  • *.background_dump_dest='C:\oracle\admin\ORCL\bdump'
  • *.compatible='9.2.0.0.0'

    *.control_files='C:\oracle\oradata\ORCL\CONTROL01.CTL','C:\oracle\oradata\ORCL\CONTROL02.CTL','C:\oracle\oradata\ORCL\CONTROL03.CTL'
  • *.core_dump_dest='C:\oracle\admin\ORCL\cdump'
  • *.db_block_buffers=480000
  • *.db_block_size=8192
  • *._db_block_lru_latches=32
  • *.db_domain=''
  • *.db_file_multiblock_read_count=16
  • *.db_name='ORCL'
  • *.dispatchers='(PROTOCOL=TCP) (SERVICE=ORCLXDB)'
  • *.fast_start_mttr_target=300
  • *.hash_join_enabled=TRUE
  • *.instance_name='ORCL'
  • *.java_pool_size=33554432
  • *.job_queue_processes=10
  • *.large_pool_size=8388608
  • *.open_cursors=300
  • *.pga_aggregate_target=117922508
  • *.processes=150
  • *.query_rewrite_enabled='FALSE'
  • *.remote_login_passwordfile='EXCLUSIVE'
  • *.shared_pool_size=354121647
  • *.sort_area_size=524288
  • *.star_transformation_enabled='FALSE'
  • *.timed_statistics=TRUE
  • *.undo_management='AUTO'
  • *.undo_retention=10800
  • *.undo_tablespace='UNDOTBS1'
  • *.use_indirect_data_buffers=TRUE
  • *.user_dump_dest='C:\oracle\admin\ORCL\udump'

What I have tried, is to decrease the AWE_WINDOW_MEMORY to 400M, also I tried to increase to 2 GB but in both scenario I receive the not enough memory error, so my first question is to confirm my AWE_WINDOW_MEMORY is really taking effect? Please help

3
  • Please share with us your findings from your own research. What have you already tried? – Deer Hunter Jul 13 '14 at 4:53
  • First I am not a DBA, what I am trying here is to increase the SGA more than 1.6 GB which is the max I can set without VLM change. So I am trying to enable the VLM and increase the oracle to make use of the available RAM space which is 32 GB. I tried reducing the AWE Memory to 400 M, increase to 2GB but I always get the not enough memory error. So I suspect either my awe_window_memory is still not considered or my pfile settings consume more than what is allowed but I can't figure out. – Swamy Jul 13 '14 at 10:40
  • 2
    The obligatory "get rid of old software and use 64-bit" comment. – MichelZ Jul 13 '14 at 11:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.