2

I've recently put together a small office network (around 20 devices) with an attached machine running Windows Server 2012. Our gateway router provided by our ISP was pretty useless and started dropping connections once there were too many devices connected to it.

I managed to solve this issue by turning off the DHCP functionality on the router and off-loading it to the Windows Server machine. This worked for all of the windows devices on the network, but there seems to be a problem getting the windows DHCP to work with *nix devices.

On both android and OSX devices the machines cannot seem to obtain an address from the DHCP. On android devices the wi-fi seems to get stuck on "Obtaining IP address" while the OSX devices seem to give up after a while and self-assign an IP address that is far outside the local address range.

I was just wondering if anyone has come across an issue like this before?

I've done a bit of research on this and it seems that *nix devices want a response from DHCP Option 119 (See: http://blogs.blackmarble.co.uk/blogs/rhepworth/post/2012/06/18/Adding-DHCP-Option-119-(Domain-Search-List)-to-Windows-Server-2008-R2.aspx )

However I went through the steps in this blog and still had no luck.

As a stopgap I have reserved IP addresses on the DHCP and manually set the adapter settings for each OSX and Android device currently on our network, but I would rather not have to do this for every new *nix machine that wants to connect.

Any help would be appreciated...

  • Is this 2012 or 2012R2 and is it up to date with patches? also are you running this box as both a DC and DHCP server and if so are you running DNS on it too? – Chopper3 Jul 15 '14 at 10:57
  • Its 2012R2 Standard, it's up-to-date. Yes the box is running as a Domain Controller, DHCP Server and DNS Server – user3241130 Jul 15 '14 at 11:03
1

I'm assuming that you are only using IPv4--if not, you need to check things in both IPv4 and IPv6.

I'd start by checking these in the DHCP server:

  1. Make sure that you don't have any policy settings that would prevent such devices from being assigned an IP address.
  2. Make sure that you have DHCP options set.
  3. Make sure you can ping to the server from the OS X devices (and visa-versa).

Follow up questions:

  1. Are OS X clients using wireless or are they hardwired in? If wireless, have you tried hardwired?
  2. What functions were served by the gateway/router provided by your ISP? Was it also your wireless access point? If so, it might not know to forward DHCP requests on to the new DHCP server. Do you have multiple devices plugged in directly to the gateway? If so, the ISP equipment might be interfering with a wireless access point that is passing through it.
  3. What does your network topology look like? Do you have everything plugged in to a switch?
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.