1

I have configured group policy to tell a particular service (Winrm) to restart when the policy is applied. When the policy applies, I see that it tries to stop and start the service. Stopping works, but when it tries to start it, I get the following error in the event log:

"The Windows Remote Management (WS-Management) service failed to start due to the following error: The account specified for this service is different from the account specified for other services running in the same process."

The account, incidentally, is supposed to be "Network Service", and it is set that way, but it still won't start through group policy.

Now, for a while I tried to start it manually from the machine itself, and got the same error, until I went in to the properties of the service, and blanked out the password.

Thing is though, when I blank out the password in group policy in the same way, that still doesn't fix the problem.

  • Have you tried using the system/local service account? – MDMoore313 Jul 15 '14 at 17:24
  • @BigHomie yes, and that results in the same error as above. It seems to really want to use the "network service" account. – user1197457 Jul 15 '14 at 18:17
0

thanks for your help, but I think I figured this one out. I just specified "no change" under the GP setting for log on as, instead of trying to set an account.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.