-3

I'm using latest NSCLIENT on a Win Server 2012, and see: Truncating return data as it is bigger then NRPE allows in the log file.

How can I fix this?

2
  • What's the version of the nsclient you're using?
    – Itai Ganot
    Commented Jul 17, 2014 at 10:39
  • version is : 0.4.1
    – JustAGuy
    Commented Jul 17, 2014 at 10:50

2 Answers 2

0

NRPE protocol has a limit for the output message which is sent back to the server. It is generally fixed to 1024 bytes.

It means that your plugins must not return a string longer that that limit.

If you can, modify your script to make them less verbose (it may be difficult if you have several metrics to send, but if it's just output string, then it may be truncated)

You can also try to modify the max length in the NSClient configuration, but you'll also have to change it in the NRPE client on nagios side, which involves a recompilation of the check_nrpe command.

0

You can recompile check_nrpe with a larger payload size (and/or the multi package patch patch).

Extending the payload size can be done by changing (http://sourceforge.net/p/nagios/nrpe/ci/master/tree/include/common.h) and recompiling check_nrpe.

Set payload to 4096

#define MAX_PACKETBUFFER_LENGTH 4096

The same value can be configure in NSClient++:

[/settings/NRPE/server]
payload length=4096

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .