10

I'm attempting to copy files from one server folder to another server folder over an RDP connection and this window pops up when I hit CTRL+C to copy the files:

Copying

There's only 12.5mb in 276 files and 49 folders being copied and it should be very fast, but it seems to be using RDP clipboard sharing since I see about 60-128kb network activity and right-click dragging the contents to the destination works quickly. If I disable clipboard sharing then CTRL+C to copy works quickly as well.

There's only one server I've noticed it on and it happened sometime in the last two months. Is there some configuration setting that might have been changed by a windows update?

What I want to be able to do is go back to how it worked before:

  1. Clipboard sharing is enabled, allowing me to copy and paste text on the clipboard between the client and server
  2. Shared drives are enabled, allowing me access to my local drives on the client in my server session
  3. Copying files between local directories on a server does not copy file contents to the clipboard on the client using rdpclip.exe (using either CTRL+C or right-click copy)
  4. Copying files from the shared folders on my client \\tsclient\xxx does not involve the clipboard, though it copies the data over the network (90% sure this is how it worked before, I didn't get any window pop-up until I pasted the files on the server)
  • I believe that your assumption is correct and I think I did some testing with this years ago. When performing certain file copy operations the data goes through the RDP clipboard, which means it goes from the source machine through the RDP client to the destination machine. Did you do this from the context menu, from the File|Copy menu or simply by dragging and dropping? – joeqwerty Jul 17 '14 at 14:59
  • Both right-clicking and selecting copy and CTRL+C with the files selected, I don't think I tried copy from the file menu. I thought I remembered dragging the files doing the same thing yesterday, , but when I tried it today it worked fine when I drug the files with the right mouse button and selected copy at the destination. – Jason Goemaat Jul 17 '14 at 18:09
  • Update: Using copy from the explorer edit menu shows the same behavior. Killing rdpclip.exe prevents this, but it prevents clipboard sharing altogether. Starting it back up didn't help. rdpclip.exe seems to have a file date of 2/17/07 so I don't think it's been updated. – Jason Goemaat Jul 17 '14 at 18:39
5
+50

You can prevent this from happening by making sure you are not sharing drives via your RDP connection.

When connecting to a server via RDP:

  • Click Show Options
  • Go to the Local Resources tab
  • Click Settings
  • Click More
  • Unselect all drives

This worked for me and got rid of the "Preparing paste information" dialog.

| improve this answer | |
  • Isn't it completely backwards? Specifically I am not copying to remote directories at all, I'm copying between two directories on the remote server. I also would like to have shared drives to let me copy files to and from them easily. Why would disabling shared drives affect clipboard copy/paste of files? – Jason Goemaat Jan 4 '15 at 10:32
  • Sorry it took a while to get back on this - I have to be honest and say I'm not intimate with the inner workings of RDP. My best guess is that when you place items on the clipboard, RDP assumes you may want to copy these files to a shared drive at some point. It may even go as far as to synchronize your local clipboard with the remote clipboard. If you need to copy files between two servers, I would recommend using FTP instead. – cswilby Mar 10 '15 at 18:28
  • Thanks for the reply. I was hoping this would be some obscure registry setting that someone might know. After all it still works that way on 2008, and only changed on 2003 when either the server did some updates or I updated to Windows 8.1 (though that didn't affect 2008 servers). I need to keep clipboard sharing enabled for sure so I guess being unable to copy files easily is the lesser of the two evils. – Jason Goemaat Mar 10 '15 at 20:52
  • this explains it all. also why my previous workaround so far, drag'n'drop, always worked. – dlatikay Apr 4 '17 at 17:17
1

I often have to copy files on machines through remote desktop. I also have drives mapped since I often need to pull these files to my machine so turning the mapped drives of is not really a solution for me.

What I found out is when you open 2 explorer windows and drag the files from one folder to another they will get copied without the annoying dialog opening. (also when copying to your local mapped drive)

My main problem with this dialog is that when I press cancel, some seconds later it will pop up again and again. Sometimes I have to click cancel 5 times before it is actually cancelled

| improve this answer | |
0

This is proper behavior when you're using clipboard sharing and it's more noticeable over a slow link. This allows you to cut and paste from a remote to local and vice-versa.

| improve this answer | |
  • Is that a setting? Something with an update to server 2003? It didn't work like that two months ago and doesn't work like that on other servers. – Jason Goemaat Jul 17 '14 at 18:10
0

This has been the case always in 2003 rdpclip when RDP drive mapping is turned on. When only clipboard sharing is turned on it does not happen. It syncs the clipboards even if right clicking in the remote window.

The simple universal solution is to never use ctrl-c and ctrl-v or right click to copy or paste in RDP sessions. Instead use drag and drop from one folder to another and this problem goes away.

| improve this answer | |
  • I don't think so. I have been copying and pasting config sections from my development computer using clipboard sharing for years so that has always been enabled. I've also used \\tsclient\c\xxx as the way to copy deployments from my computer. And I"ve also copied rather large directories around on the server using CTRL+C and CTRL+V and right-click copy/paste and never had an issue until last year. Windows 2008 server doesn't do this but both the servers we still have running 2003 do. I've been using the two servers with recent issues since 2008. – Jason Goemaat Mar 8 '15 at 10:24
  • It might have something to do with the client... I'm not sure exactly when it happened but it might have been around the time I upgraded my client computer to Windows 8.1... – Jason Goemaat Mar 10 '15 at 2:50
  • @JasonGoemaat ...or just never use right click or ctrl-c and ctrl-v to copy and paste, drag and drop instead and you can maintain clipboard while avoiding this problem. – jotap Apr 21 '15 at 5:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.