Quite a perplexing one.

I have a Windows 8.1 machine (completely up to date on patches from Windows update) that I want to join a Windows Server 2008 (R1) domain. When I log into the local administrator account and choose to join the domain (i.e. "WinDom"), it says "Welcome to WinDom" but then follows this up with a pause and then an error message "Changing the Primary Domain DNS name of this computer to "" failed."

Ignoring this, I reboot and am able to log in to WinDOM\User which then creates a local account on the Windows 8 computer and a computer object in Active Directory on Server 2008 (so it is seeing the domain initially). However after logging in, it stops seeing the domain properly and subsequent reboots results in "There are currently no logon servers available" locking me out of the account on the machine that was just created.

If I run "nltest /dsgetdc:WinDom" on the Win 8 machine when it's not on the domain, it reports it can see the domain controller fine. If I join the domain and then run the same command it cannot see the domain controller anymore.

Whether it is on the domain or not, I can use nslookup to find the domain controller server and ping it so I don't think it's a general DNS issue. The DNS/DHCP server is not the same as the Windows Domain Controller server and both the server and the Windows8 machine have the IP set as it's preferred DNS server.

We have another dozen Windows 7 machines all working happily on the domain, it's just the Windows 8.1 machine I'm having trouble with

Anyone have any ideas what's going wrong here?

Thanks in advance for any light anyone can shed on this.

I'm going to try patching the Windows Server 2008 this weekend to see if anything there adds support/fixes for Windows 8 machines joining the domain, but I'm going around in circles at the moment.

  • The DNS/DHCP server is not the same as the Windows Domain Controller server and both the server and the Windows8 machine have the IP set as it's preferred DNS server - What does that mean exactly? Does it mean that the AD DNS server is not running on the DC? Where is the AD DNS server? Are the AD zones correct on the AD DNS server? Basically what I'm asking is if you're using a DNS server that hosts your AD related DNS zones or are you using an unrelated DNS server, such as your ISP? – joeqwerty Jul 17 '14 at 14:56
  • Sorry if that wasn't clear. The DNS/DHCP server is a different server than the domain controller. So the DNS/DHCP server is "server A" and the domain controller (that's running active directory) is "server B". Both the Windows 8 machine and "server B" in the network adapter settings has the "use the following DNS server address" set to the IP of "Server A". The DNS server is not a Windows machine (it's Linux) but all the Windows 7 machines, phones, network switches and other devices on our network look up from it just fine (Windows 8 can use it in ping and nslookup with no issue) – Psychobob Jul 17 '14 at 15:31

I believe that I know what the problem is... To eliminate the error, either:

Verify that NetBIOS over TCP/IP is enabled.

  1. Click Start , click Run , type ncpa.cpl , and then click OK .
  2. In Network Connections , right-click Local Area Connection , and then click Properties .
  3. Click Internet Protocol Version 4 (TCP/IPv4), and then click Properties .
  4. In the Internet Protocol Version 4 (TCP/IPv4) Properties dialog box, click Advanced .
  5. On the WINS tab, verify Enable NetBIOS Over TCP/IP is enabled, and then click OK three times.


Verify end-to-end network connectivity over UDP port 137 over the network path connecting the client being and the helper DC serving the join operation.


If the error occurred in an IPv6 only environment OR you require a fix to resolve the error, open a support incident with Microsoft Customer Service and Support requesting a post RTM fix for Windows 8 .

| improve this answer | |
  • Thanks, afraid I already tried this (should have mentioned that). I've tried turning off the firewall on the both the Windows 8 client machine and the Server 2008 machine to be sure it wasn't a port issue, but no dice. I also tried the NetBIOS options and Ipv6 is disabled in the network adapter settings on the server and the client machine – Psychobob Jul 17 '14 at 15:32
  • @Psychobob Please edit your question to include what was done in previous attempts to solve the problem :) – Signal15 Dec 20 '14 at 2:24
  • Reenable IPv6. See technet.microsoft.com/en-us/network/cc987595.aspx – Jim B Dec 20 '14 at 2:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.