I am trying to configure roundcube webmail and I get the error

"Can't initialize character set utf8 (path: /usr/share/mysql/charsets/))"

I fixed this before on my website by adding ;charset=UTF-8 to the end of the "mysql:host=" line for my db connection. This means a utf8 charset exists but it is being picky about the format.

I have tried adding the following to /usr/share/mysql/charsets/Index.xml

<charset name="utf8">
  <description>UTF8 Unicode</description>
  <collation name="utf8_general_ci" id="33">
  <collation name="utf8_bin"        id="83">

I still get the same error message. How do i add a new charset or overcome this issue with mysql requiring the charset to be specific.

I have tried searching through the php files for roundcube hoping to find the db connection line so i can add the - to uft8 but i am unable to find it.

  • Where exactly is that error coming from? That doesn't look like a standard Mysql error message. – Zoredache Jul 17 '14 at 21:15
  • is shows up in the mysql error log. I changed the uft-8 charsets name to utf8 and it fixed the problem. it just seems weird that there cant be 2 – Dan Hastings Jul 17 '14 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.