1

I have an operating Domino mail server which receives email for one internet domain - acme.com and now I would like to configure another internet domain, french version of emca.com.

Global domain document is configured to receive emails for both primary domain of acme.com and new French version of emca.com.

User testuser has been configured with two email aliases in FullName field, one for each domain. My problem is that email is received successfully when sent to testuser@acme.com, but when sent to testuser@emca.com I get the following error:

rejected. 554 5.1.2 Recipient address rejected: User unknown Google tried to deliver your message, but it was rejected by the server for the recipient domain emca.com by mail.emca.com.

My question is: What are the steps to begin troubleshooting such an error?

Many thanks for any suggested places to look; I'm out of ideas even though I'm a Domino admin for 20 years now. I'm sure I'm just overlooking something basic, as I have this working a zillion other places.

  • Where did you put the second domain in your global domain document? What does the hidden ($Users)- view say? Do you find the emca- addresses there? Did you check the "Router/SMTP - Restrictions and Controls - SMTP Inbound Controls" for "Allowed internet domains"? – Torsten Link Jul 18 '14 at 13:16
  • Hey Torsten, so you're over here too eh? Well I checked the ($Users) view, yep, it's showing. As for "Allowed internet domains", all the fields with that kind of wording are either blank or have a * in them, so I think they are good. Good ideas though, worth checking, I may be missing something blazingly obvious. (Or, it could be a spam or firewall issue eh?) – Randal Oulton Jul 18 '14 at 17:05
  • Do you have any SMTP Internet Site Documents configured in this server's names.nsf? – rhsatrhs Jul 19 '14 at 6:17
  • Have you tried a Tell router update config on the domino server? Does the address work also internally, when send from one user to another? Sometimes SMTP mailserver cache the last result for some time, which might be the case for google. – BastianW Jul 19 '14 at 11:59
0

As stated in the comment there are some places to look at for making a second domain work.

First of all you have to make the domino aware, that it is responsible for this domain. Therefor you either edit an existing Global Domain document and add the domain to the list of alias domains (take care: the domain field is single value in this form), or you create a second Global Domain document with the new domain.

Then you have to check the smtp inbound settings in the configuration document, if inbound mails are restricted to specific domains (they by derault aren't).

In the last step you add the new domain to a users mail address. Then I usually check using telnet to be sure, no other component is involved:

Telnet yourdominoserver 25
Helo itsme
Mail from: me@gmail.com
Rcpt to: user@newdomain.com
Data
Subject: test
This is a test
.

If this doesn't work you can disable the option "Verify that local domain recipients exist in the Domino Directory" to check if it is a user problem or a domain problem.

During your tests always watch the console: set mail logging to a high level (configuration document - Router/SMTP - advanced - Controls - Logging level) and check the exact message on the log...

  • Thanks Torsten -- that confirms that I'm not losing my mind, that that really is all that I should have had to do, so I'll keep trying to see what else the problem could be. – Randal Oulton Jul 19 '14 at 16:20
0

Turned out to be Brightmail spam filter that was blocking all incoming email on the second incoming internet domain.

Thanks for the suggestions all, it gave me the confidence to know that indeed I wasn't missing anything dumb and obvious in Domino! (Sometimes after all these years you wonder if you are overlooking something basic!)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.