8

I am trying to configure Web Deploy 3.5 on Windows Server 2008 R2 Standard with SP1 installed on it. When I try to validate connection using Visual Studio 2013 to publish a website it throws the following error.

Could not connect to remote computer (computer name). Make sure Web Management Service is started.
Learn more at http://go.microsoft.com/fwlink/?linkId=221672#ERROR_DESTINATION_NOT_REACHABLE

enter image description here And I have tried everything found on all the forums as follows. And I have also done this before at a different job and every time it worked just fine.

  1. Made sure Web Management Service is started and set to Automatic
  2. Made sure that Web Deployment Agent Service is started and set to Automaticenter image description here
  3. Web Deploy 3.5 is installed
  4. I have tried installing different version of Web Deploy 3.5 too like the hosting versions.
  5. I checked if the firewall port for Web Management Service is listening on 8172 port (see image below).enter image description here
  6. The .Net Framework version I think that is not an issue.
  7. I have also made sure that during installation of Web Deploy 3.5 all the components are installed.
  8. When I click on the server node inside IIS and inside Web Management Service it also says Enable Remote connection
  9. I have also checked if users are delegated to publish on that website.
  10. I don't find any logs inside C:\inetpub\logs\wmsvc either.

I cannot ping the 8172/webdeploy.axd url. Is there any other service that could be listening on some port that I am missing. Something is odd here. I cannot see any traffic going through even Fiddler from my local machine. I have tried to paste the .axd url on the server's internet explorer and it still cannot reach it and doesn't say anything.

More Finding:

I tried to connect using Telnet client and it says: Could not open connection to the host, on port 8172: Connect failed. Somewhere it is blocked and I have no idea where to look for.

7

A comment on this answer at stackoverflow got me on the right track with this same error message if anyone else comes across this and the other answers don't help: https://stackoverflow.com/a/13871041/1128742.

Not only does web deploy need to be installed, but the IIS Deployment Handler subitem needs enabled. Open up Add/remove programs > Microsoft Web Deploy > Change > make sure IIS Deployment Handler is Enabled. enter image description here

Web deploy was working for us then we applied some windows updates and it stopped working suddenly, this was the culprit.

2

So the issue turned out to be there was another firewall preventing any connection to 8172 port and it had to be opened up.

2

I've just had similar problem. It was due to messing with SSL certificates.

During the installation of WebDeploy you normally install Management Service which creates self-signed certificate named: WMSvc-HOSTNAME.

This certificate should be available in Certificate Store:

enter image description here

and should be visible in IIS under Server Certificates:

enter image description here

Since I was messing with it somehow WMSvc-HOSTNAME was available in Certificate Store and disappeared from Server Certificates in IIS.

The problem was that Management Service was configured to use WMSvc certificate:

enter image description here

Solution:

Create new Self-signed SSL certifcate and used it with Management Service instead of WMSVC one.

  • 1
    That was exactly my issue. The SSL certificate was missing from IIS -> Management Service. – Alin C Jun 28 at 15:19
2

I had the same problem (404). Fixed it by:

  1. Uninstalled Web Deploy 3.6 from Programs & Features
  2. Downloaded x64 package from https://www.iis.net/downloads/microsoft/web-deploy#additionalDownloads
  3. Installed downloaded MSI package, which turned out to be Web Deploy 3.5.

Immediately (without a restart) this resolved the issue.

  • Saved my day! I was getting a 403.503 when publishing a solution from visual studio to my server on Windows 2012 R2. I tried so many solutions out there, but this one ended up being THE one. Thanks Aidan! – Pallavi Nov 5 '18 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.