0

First time using php 5.5 and well I'm getting a lot of headaches.

I can't install php-mysql, I get the following error:

Error: Package: php-mysql-5.4.30-1.el6.remi.x86_64 (remi)
       Requires: php-pdo(x86-64) = 5.4.30-1.el6.remi
       Installed: php-pdo-5.5.14-2.el6.remi.x86_64 (@remi-php55)
           php-pdo(x86-64) = 5.5.14-2.el6.remi
       Available: php-pdo-5.3.3-26.el6.x86_64 (base)
           php-pdo(x86-64) = 5.3.3-26.el6
       Available: php-pdo-5.3.3-27.el6_5.x86_64 (updates)
           php-pdo(x86-64) = 5.3.3-27.el6_5
       Available: php-pdo-5.4.29-3.el6.remi.x86_64 (remi)
           php-pdo(x86-64) = 5.4.29-3.el6.remi
       Available: php-pdo-5.4.30-1.el6.remi.x86_64 (remi)
           php-pdo(x86-64) = 5.4.30-1.el6.remi
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

What do I do?

  • you have Installed: php-pdo-5.5.14 from @remi-php55 – ADM Jul 20 '14 at 19:31
2

You forgot to enable the remi-php55 repository from which you intended to get the packages.

You should make this persistent by editing the repo configuration file /etc/yum.repos.d/remi.repo and ensuring that the remi and remi-php55 repos are enabled.

  • +1, correct, you've enabled remi but not the sub-repositories. You could also uninstall remi mysql and install the standard mysql and just rely on centos / epel, but remi's packages will work too. – Alex Berry Jul 21 '14 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.