2

I'm running a Wheezy box in KVM, by default it runs the kernel 3.2. After I upgrade to 3.14 from backports, I no longer can tune the IO scheduler.

Before:

# cat /sys/block/vda/queue/scheduler
noop deadline [cfq]

# echo noop > /sys/block/vda/queue/scheduler
# cat /sys/block/vda/queue/scheduler
[noop] deadline cfq

After:

# cat /sys/block/vda/queue/scheduler
none

# echo noop > /sys/block/vda/queue/scheduler
# cat /sys/block/vda/queue/scheduler
none

The host and VM configuration are untouched. What could be the problem?

3
  • do you have any error in your messagges when you try to change the io scheduler?
    – c4f4t0r
    Commented Jul 21, 2014 at 8:44
  • @c4f4t0r no, nothing at all.
    – bereal
    Commented Jul 21, 2014 at 9:25
  • It doesn't make sense to use anything other than none. Commented Oct 30, 2015 at 15:06

2 Answers 2

1

The kernel you updated to likely does not have scheduler support you are looking for

e.g. you should be seeing something like this

egrep 'CONFIG_IOSCHED_.*=y' /boot/config-`uname -r`
CONFIG_IOSCHED_NOOP=y
CONFIG_IOSCHED_DEADLINE=y
CONFIG_IOSCHED_CFQ=y

Where did you get that 3.14 kernel? If you were building it make sure you have those config options set for your build.

0

This may be a feature rather than a bug. I am seeing the same on CentOS v7.1 https://access.redhat.com/solutions/1305843

1
  • great answer ... a link to an board, where you should be a subscriber ...
    – demonking
    Commented May 2, 2018 at 9:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .