A short overview:

  • Server running Windows Hyper-V Server 2012 R2 Core "Adama", up to date
  • Core is accessible via RDP Running VM with Windows Server Essentials 2012 "Apollo", also up to date and accessible via RDP
  • Apollo functions as a File server, AD Services haven't been activated yet, so there is a domain, but unused, everything goes via WORKGROUP
  • Client running Windows 8.1 Pro, up to date
  • All via local network

My situation:

Everything used to be running well, all the mmc snap-ins were available on the client, etc, etc... The last time I used the Hyper-V Manager on the Client has been more then a month ago. Today I fired it up, wanting to add a new VM for a postgresql DB, and I'm unable to connect to the Hyper-V server with the know error "An error occurred while attempting to connect.... Check that the Virtual Machine.... authorized to connect to ...."

I've been checking anything I (and google ;)) can think of, all accounts seem to be in order via cmdkey, via mmc I can connect, but not to the Disk Management (Unable to connect to Virtual Disk Service), Device Manager. The Firewall isn't accessible anymore, but the Task Scheduler, Performance, Users, etc... are still accessible...

So in short, to me it seems to be a firewall issue, but I'm not well versed in the windows firewall and all it's possibilities, if anyone has any idea/suggestions?

Thanks & regards,

Fre

I would try running HVRemote on the server using the appropriate command line for your scenario and see whether it resolves your issue.

Latest version and brief documentation can be obtained here: http://code.msdn.microsoft.com/windowsdesktop/hyper-v-remote-management-26d127c6

  • Oh that's a good idea! I wish I'd have thought of it sooner! ... oh wait I did :P – Aceth Jul 22 '14 at 18:35
  • 1
    You're not the asker of the question, and the OP didn't state they had tried the HVRemote script already. I'd rather mention the more obvious steps and risk someone feeling patronised (not intended) than leave them without what could be helpful information. – dbr Jul 22 '14 at 18:52

http://nearlydeaf.com/?p=1149

Try this - I'm having the exact same issue although mine is on a domain.

Also, check the local users on the hyperv box to see if password has expired?

  • I went through everything the linked guide said to no avail. I had added the credentials of the server to the client with cmdkey, now I've created two idential local accounts on the client & server with also no change. The used account on the server was said to never expire. – Fre De Peuter Jul 21 '14 at 12:10
  • Can the hyperv server resolve your clients hostname correctly? (hint try putting the hostname in to the hosts file). – Aceth Jul 21 '14 at 13:49
  • are you running any AV/Firewall on your client? The hyperv has to connect back to your client PC. I just fixed my issue by disabling Symantec endpoint!! :D – Aceth Jul 21 '14 at 13:50
  • and you've done the dcomcfg.exe anon access? – Aceth Jul 21 '14 at 13:50
  • - resolving of hostnames works both ways (on the client the server is in the host file). - on the client just windows defender & firewall, turning them off didn't make a difference - Done the dcomcfg anonymous access – Fre De Peuter Jul 21 '14 at 15:41

HERE IS WHAT WORKED FOR ME: Create an admin acct on the client and also the same acct on the Hyper-V server with same passwords. On the client, launch Hyper-V manager by holding shift and right click, then, use different credentials (the one you made earlier).

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.