0

I have set up an apache2 server. I am trying to enable a site to reverse proxy in which I will redirect /registry to :5000.

I have apache2 up and running and am able to reach the default page () but am having trouble getting my reverse proxy to work. I have created a file as such:

<VirtualHost *:80>
#
ServerName http://myhost.org
#
    DocumentRoot /var/www
    ProxyPreserveHost On
    ProxyRequests off
    ErrorLog ${APACHE_LOG_DIR}/error-docker.log
    CustomLog ${APACHE_LOG_DIR}/access-docker.log combined
    ProxyPass /registry myhost.org:5000
    ProxyPassReverse /registry myhost.org:5000
#
</VirtualHost>

When I go to the url myhost.org/registry I get the following:

Not Found

The requested URL /registry was not found on this server.

I know the site is enabled because I have checked this:

sudo a2ensite proxiedhosts
Site proxiedhosts already enabled

Any help with the issue would be greatly appreciated.

  • Figured it out. I had the path set wrong (/var/www) was incorrect. I just removed that line and it works. – catagon87 Jul 21 '14 at 21:33
2

Sorry. I figured this out. Looks like the problem was my path in /var/www/ was incorrect.

It was essentially referencing a path that did not exist.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.