0

I'm not a Java developer, my knowledge is very limited to this topic. I want to deploy a .war webservice on my Tomcat server, which fails most likely because of its Derby dependency (just a guess from catalina.log). So I'm now struggling with Derby installation. First of all I've been said, it's included in the newest JDK, but there was no such package available for download. This version is all I could get from yum:

java version "1.7.0_65"
OpenJDK Runtime Environment (rhel-2.5.1.2.el6_5-x86_64 u65-b17)
OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)

Stupid question, but is this the JDK or just the JRE? I downloaded and extracted Derby manually, I want Tomcat to know that Derby exists. How do I do this? Hope, I haven't completely misunderstood things.

java org.apache.derby.tools.sysinfo

returns Error: Could not find or load main class org.apache.derby.tools.sysinfo

Thanks for any advice.

0

The default package manager of Cent OS, yum doesn't have the correct JDK's in the repositiories. (didn't try with rpm though) Looking up either version of "jdk" and installing it would install only the JRE with or without some docs. Thus the solution for question above is installing JDK from the correct source: Oracle.com. (Registration is needed). It's advised to download the executable, .rpm.bin file instead of tar.gz, so it can easily be installed with:

chmod +x jdk6u45.rpm.bin
./jdk6u45.rpm.bin

JDK 6+ includes Derby and JDBC by default.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.