0

I know nothing about IIS, but this should be pretty straightforward.

We have setup and deployed Remote Desktop Services on Windows Server 2012. That is working great, internally. I am trying to set it up so we can access this externally.

  1. I've got the firewall allowing incoming connections to that IP with https

  2. I've got a static map that maps the public static IP with the internal private IP of that server

  3. I've got an a record on network solutions that shows the public IP correctly when pinged

  4. When I put that name into a browser (externally), I am presented with the default IIS 8 splash page, and it does show SSL as working.

So with all that said, I think something simple needs to be redirected or changed in IIS so that we can pull up the RDWeb Gateway page, that will have a link/download to an RDP file so they can then use remote desktop.

Can one of you please show me and tell me where to go in IIS?

  • What's the problem here? You forgot to include information about what's not working about your setup. – HopelessN00b Jul 24 '14 at 18:57
  • When i type in the name in a browser, i am only seeing the IIS 8 default splash page, I should be seeing the RDS web access page, that either hosts public apps, or remote desktop profiles, which can be downloaded, and then they load up remote desktop. So where do i go in IIS to enable that website, and get rid of the iss 8 default page. – Dirk Diggler Jul 24 '14 at 19:06
0

To access Remote Desktop Web, use the following URL:

http://rdp.example.org/RDWeb/

Where rdp.example.org is your Remote Desktop Server web gateway.

See: http://technet.microsoft.com/en-us/library/cc731508.aspx

  • thanks, but don't i need to mess with something in IIS on the web access server? – Dirk Diggler Jul 24 '14 at 19:35
  • Not when I used it in 2008... things may have changed. – gparent Jul 24 '14 at 19:42
0

Your problem is that you're using the root of the host as your url. By default, on a system with IIS enabled, that goes to the IIS welcome page. In order to connect to a site running on that IIS instance, you need to:

  1. Type in the actual url of the web service you have installed.

  2. Redirect the https://[hostname]/ to https://[hostname]/RDWeb

  • This area is pretty much what i have been reading about all day, but i'm not really sure where to go. MY RDS servers are as follows: RDS01-web access/connection broker RDS02-rd gateway RDS03-remote session host Where do i make this change at? I'm thinking i need to do it on RDS01 since that is the web access, right? Additionally, internally i can get to the web access via RDS01.domain.com/RDWeb/Pages/en-US/Default.aspx there it shows the RDP file, that i can download or open and fire up remote desktop. It seemed like whenever i made changes to RDS01, nothing happened externally – Dirk Diggler Jul 24 '14 at 21:23
  • When i was trying it on my home computer, since it's external. Nothing was changing when i was messing with RDS01. I started messing with the same http redirects on RDS02, and then when i would go to that public name of remote-gw.domain.com it would forward me to rds02-domain.com/RDWeb. So it's like i think i am supposed to make changes on RDS01, but am confused because i'm only seeing these external changes when i mess with RDS02. Thanks guys – Dirk Diggler Jul 24 '14 at 21:30
  • @DirkDiggler Sounds like you might need to do some reading on RDS farm architecture/design and how the various servers and services work together... and maybe ask a different question once you've done that. – HopelessN00b Jul 24 '14 at 21:33
  • RDS all works internally, just not externally. Which is why im having issues with iis. Again, i have no idea about iis, but that is where the problem is. Getting the service to show up publicly in iis as simple as messing with the http redirects? and i think what i was wondering is on RDS01 in iis there is a default website and an RDweb, which one, or both do i mess with the http redirects? No one mentions that in any of the articles/blogs. Secondly, on RDS02 in iis, i see default web site, and rpc and rpcwithCert. So again, i think i need to be messing with RDS01 and not 02. – Dirk Diggler Jul 24 '14 at 21:41
  • ...and get this. Finally got ahold of my boss and turns out he doesn't want to display the web portal anyway. Instead we want to use the gateway, and the special rdp file that we already have. We just need to distribute the special rdp file and everything is good to go. Spent like 15 hours with this since wednesday...i hate myself. thanks for your time though man. – Dirk Diggler Jul 25 '14 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.