2

Just installed StartSSL certificate on my debian wheezy, nginx 1.6 server.
Everything seem to be working fine, I can browse the website in https no problem until I try to login...
IE works fine and I can login to OK.
Chrome gives me this error: Error code: ERR_SPDY_PROTOCOL_ERROR
Firefox just hangs and does nothing.

When I scrap the StartSSL cert and use selfigned cert everything works fine again, I'm able to login without any problems.

My nginx config:

server {
     listen 443 ssl spdy;
     server_name test.com;
    root /home/www/test.com/;
    ssl on;
    ssl_certificate        /etc/nginx/certs/test.com.crt;
    ssl_certificate_key    /etc/nginx/certs/test.com.key;

     access_log /logs/access.log;
     error_log /logs/error.log;
     error_page 404 /404.html;

     location / {
         index index.php index.html index.htm;
         try_files $uri $uri/ /index.php?$args;
        }

..........
.........
}

Any suggestions as what might be wrong?

2
  • What's in the error log? – Michael Hampton Jul 24 '14 at 20:56
  • I had the same problem. Log entries seem to be normal, you notice the error only in the client. In my case, images were only partially displayed. The answer from @dev-chakraborty solved it. – Trendfischer Apr 9 '15 at 12:12
2

I encountered this issue because I had changed the nginx user, and it did not have access to /var/lib/nginx. I solved the issue by chown'ing /var/lib/nginx for the new user.

0

In case it helps anyone in the future as this is one of the top search results, I had this error but for a reason I haven't seen mentioned yet.

Although it looked like Nginx at fault, I had other sites running fine on similar configs on the same server. Turns out it was actually a fault in a PHP header redirect, one of our programmers had forgotten to put "Location: " in before the address, which it seems broke the header and caused this error in Chrome. All other browsers just ignored it.

Since it was the first line in index.php it broke before seeing any of the site, making it look like it was affecting the whole site, but it was just that page.

0

Adding appropriate Content-Type header fixes it.

["Content-Type"] = "text/html; charset=utf-8"

Not the answer you're looking for? Browse other questions tagged or ask your own question.