2

I'm trying to install a vagrant plugin

$ vagrant plugin install vagrant-aws

which exits with this error:

Make sure that `gem install nokogiri -v '1.6.3.1'` succeeds before bundling.

When I try that command

$ gem install nokogiri -v '1.6.3.1'

It fails because the version of libxml2 I have is incompatible (requires < 2.9.0 and I have 2.9.1 installed with the system. I cannot downgrade or uninstall it because it has a million dependencies.)

I've gotten nokogiri to successfully install with:

$ gem install nokogiri -- --use-system-libraries=true --with-xml2-include=/usr/include/libxml2/

Yet when I run the vagrant plugin install command again, it still exits with the same error.

How can I either a) get vagrant to recognize that that gem is already installed or b) get vagrant to use the --use-system-libraries=true etc. install parameters?

2

Try the following:

$ export NOKOGIRI_USE_SYSTEM_LIBRARIES=true
$ vagrant plugin install vagrant-aws

Source: https://github.com/mitchellh/vagrant/issues/3769

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.