I'm trying to install a vagrant plugin
$ vagrant plugin install vagrant-aws
which exits with this error:
Make sure that `gem install nokogiri -v '22.214.171.124'` succeeds before bundling.
When I try that command
$ gem install nokogiri -v '126.96.36.199'
It fails because the version of libxml2 I have is incompatible (requires < 2.9.0 and I have 2.9.1 installed with the system. I cannot downgrade or uninstall it because it has a million dependencies.)
I've gotten nokogiri to successfully install with:
$ gem install nokogiri -- --use-system-libraries=true --with-xml2-include=/usr/include/libxml2/
Yet when I run the
vagrant plugin install command again, it still exits with the same error.
How can I either a) get vagrant to recognize that that gem is already installed or b) get vagrant to use the
--use-system-libraries=true etc. install parameters?