0

I have just tried moving the log location for the SQL server 2008 R2 logs as I have a fairly small System disk due to the massive size of the Winsxs folder, and now I am getting the following error in the logs:

initerrlog: Could not open error log file 'D:\SQL ERROR LOGS'. Operating system error = 5(Access is denied.).

I have ensured that the account the SQL Service is running under has full control in the ACL of the new destination.

I've now changed it back to the original location and the service still won't start, reporting the same error.

I've tried deleting the logs to see if that helps but to no avail.

Anyone seen this before?

1

I have fixed the problem now.

The problem was that I didn't have the 'ERRORLOG' file name in the path in the SQL configuration manager for the SQL service:

D:\SQL ERROR LOGS\ERRORLOG

The error thrown in the event log says 'access is denied' which makes you think it's a permissions issue. It's my bad as I didn't realize that the original path I was replacing had the name of the log file in. I thought that it just needed the path and the file would be created.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.