1

(I hope this is the right place for this type of question)

I'm trying to install cURL on a SuSE Linux Enterprise Server 11 sp3 machine. I'm using this action to do so:

sudo zypper install php53-devel

And I get this error message:

Refreshing service 'susecloud'. Problem retrieving the repository index file for service 'susecloud': Download (curl) error for 'http://default-ec2-update.susecloud.net/repo/repoindex.xml?cookies=0': Error code: Unrecognized error Error message: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

Check if the URI is valid and accessible. Retrieving repository 'SLE11-SDK-SP3-Pool' metadata [] Download (curl) error for 'http://default-ec2-update.susecloud.net/repo/update/SLE11-SDK-SP3-Pool/sle-11-x86_64/repodata/repomd.xml': Error code: Unrecognized error Error message: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

Abort, retry, ignore? [a/r/i/? shows all options]

I have very little understanding on this kind of stuff and I don't know what command should I use to update (or install?) a CA cert. I don't know where are my certificates and how do I update them.

If you can help me with this or guide me to a solution, that would be great.

Thanks.

1 Answer 1

1

It appears there's a problem with SUSE on AWS the past few days.

https://forums.aws.amazon.com/thread.jspa?messageID=559135

Apparently the DigiCert High Assurance EV Root CA cert has expired this afternoon.

This appears to affect other systems as well. https://blog.digicert.com/expired-intermediate-certificate/ https://news.ycombinator.com/item?id=8094072

4
  • So it's only a matter of time?
    – neo
    Jul 29, 2014 at 6:00
  • @Amitay Presumably. The thread says it has been resolved now, give it a shot.
    – ceejayoz
    Jul 29, 2014 at 13:50
  • I just did, and it is fixed, now I need to understand how to install the curl, because now it tells me that it can't find the php53-devel package :\
    – neo
    Jul 29, 2014 at 14:01
  • I've opened a new question about it here - serverfault.com/questions/616316/install-curl-on-an-amazon-suse
    – neo
    Jul 29, 2014 at 14:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .