1

I'm an IT professional working out of my home office. I'm having some performance problems (NAS file copies) which I'm trying to isolate, using iperf. My question is on iperf.

Infrastructure - Gigabit switches (Netgear), not crossing switches. All adapters GigE.
Server 1 - Ubuntu 12.04, running Samba
Server 2 - NAS4Free - running on VMware ESXi 5.5

My original problem - Large file transfers (1GB), particularly receive (client requests a file from server) is very slow, 10X slower on the NAS4Free box than the Samba Server. In general I'm testing using a Windows client but I'm getting similar results from a Linux client (also Ubuntu). This is provided for informational purposes. I think the iperf results highlight the problem and that is where my question lies.

I ran iPerf, using the defaults (TCP). Both servers are about the same showing 690MBytes and 683MBytes transfer speeds. That's decent throughput and doesn't seem to be the problem.

I ran iPerf set up for UDP (both server and client). I stepped up the bandwidth by 100's - up to 800m (iperf -c ip-addr -u -b 800m). These results clearly show a problem on the NAS4Free unit (running under VMware)

On Ubuntu/Samba - I can see when I hit the bandwidth limits. Jitter and discards remain low, with the worst case at 700m where jitter was .053 and I lost 193 frames out of 527954 for a .037% loss.

I have two more virtual machines on the ESXi host, running Ubuntu 12.04. They're running the same drivers on the virtual NICs as the NAS4Free box. Like the Ubuntu/Samba standalone unit there was no excessive packet loss even when the transfer is saturating the line.

On NAS4Free - It's a different story and I start getting packet loss between 300m and 400m and it just gets worse. This seems to be the problem.

Performance Table
            Bandwidth        Jitter           Lost/Total Datagrams
  -b 100m = 101Mbits/sec     0.030 ms         0   / 85471 (0%)
  -b 200m = 202Mbits/sec     0.026 ms         196 /172284 (0.11%)
  -b 300m = 301Mbits/sec     0.031 ms         514 /256312 (0.2%)
  -b 400m = 390Mbits/sec     0.037 ms        11861/343757 (3.5%) 
  -b 500m = 391Mbits/sec     0.053 ms        45983/378627 (12%) 
  -b 600m = 393Mbits/sec     0.061 ms       146109/480261 (31%)  

Any thoughts on what's causing this? What should I be looking at? What tests should I run?

Thanks in advance for any help. Apologies up front. I don't often post (anywhere) so I hope I provided the proper amount of information in a reasonable format.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.