5

I've huge problems with backup of Hyper-V on handful of HOSTS. During backup done by the software some machines become unavailable, host starts dying etc. We tracked this to not the software itself but file copying. Just doing file copy from drive D to C of size 30GB will kill off the HOST during file transfer. The ram usage before file copy is 48gb used out of 64GB. When you start the transfer of 30GB file the usage of ram changes and in 1 minute it's 64 out of 64 server starts crawling and even RDP, physical access stops working until the file copying is done. So during backup it can take hours for the servers to be avaialble.

This is a DELL Server R515 with RAID controller in mode Write-back. I've noticed this on other Windows 2012 servers. I tried using some old solutions to disable cache from 2003 but none are working. I've tested it on both IBM and Dell servers and behaviour was very similar. Ram usage going up. First it's starts with 700MB/s speed copy and then after ram is used it's going slowly. So the question is how to disable file caching or limit it to normal values.

Please don't give suggestions to use robocopy, or other "copying" tools because while it may solve the problem with copying by using external software my problem is actually about backups taken by 3rd party software which i have no influence on. I would like "Explorer" to behave normally :-)

0

Run this as administrator at the command line:

fsutil behavior set memoryusage 0 

You can set three values to this entry: 0 for not set, 1 for default, and 2 for increased.

  • Unfortunetly 0 doesn't work. Configures the internal cache levels of NTFS paged-pool memory and NTFS nonpaged-pool memory. Set to 1 or 2. When set to 1 (the default), NTFS uses the default amount of paged-pool memory. When set to 2, NTFS increases the size of its lookaside lists and memory thresholds. (A lookaside list is a pool of fixed-size memory buffers that the kernel and device drivers create as private memory caches for file system operations, such as reading a file.) You must reboot your computer for this parameter to take effect. – MadBoy Jul 31 '14 at 21:33
0

What is killing your server is not disk caching or ram usage per-se, rather the copy operation itself. In fact, non-dirty pages can be immediately reclaimed if memory pressure occurs.

Basically, during the copy you are constantly submitting I/O requests faster than the disks can handle, bringing the system to a crawl. While disabling the write back caching (both at OS and RAID card level) can give somewhat better performance, the real solution is to schedule such operating during a low load time (eg: night hours) or, alternatively, you can throttle back the copy speed (to not burn all available IOPS).

  • Actually I've been working with both Dell and Microsoft for a while now (still not solved) and it seems it's only behaving like that on Windows 2012. Windows 2012 R2 etc are just fine. They said it's the drivers... the thing is those are internal Microsoft ones. We've upgraded every single driver etc still bad. And clean Windows 2012 R2 works normally. There's surely a bug somewhere in there. – MadBoy Jun 25 '15 at 20:19
  • If you are certain it's a bug, open a ticket with Microsoft support. It'll be free if it's a bug and I've been told there is a chance to get a hotfix. – Daniel Jan 27 '16 at 5:27
0

Just so anyone is wondering... it acted like that on Windows Server 2012. Upgrade to Windows Server 2012 R2 helped. Microsoft refused to patch it because they said it's a problem with Dell (they did all the troubleshooting and pointed at cache issues), and Dell refused to help because apparently the server was bought without a license which is only partially true because the server was actually bought with a license from Dell but thru reseller which most likely did sell from 2 different sources.

So we bought a new license and servers worked after that. Still pain.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.