3

This question already has an answer here:

I'm trying to install php-devel on an AWS EC2 server so I can compile a PHP extension. But I get an conflits error.

--> Processing Conflict: httpd24-2.4.10-1.59.amzn1.x86_64 conflicts httpd < 2.4.10
--> Processing Conflict: httpd24-tools-2.4.10-1.59.amzn1.x86_64 conflicts httpd-tools < 2.4.10
--> Finished Dependency Resolution
Error: httpd24-tools conflicts with httpd-tools-2.2.27-1.3.amzn1.x86_64
Error: httpd24 conflicts with httpd-2.2.27-1.3.amzn1.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Looks like it want me to downgrade httpd24 to 2.2, but I had to change for 2.4 a few months ago in order to get SSL working...

I'm a noob at linux server admin, could anyone help me please ? Thanks

Versions
OS : Amazon Linux 2013.3
PHP version : 5.4.26
httpd version : 2.4.10

Command : yum install --enablerepo=remi php-devel
Remi repo being http://rpms.famillecollet.com/enterprise/6/

PS : I found a file that seems to be ok at choon.net, but I don't really know if I can install it without any risk. http://choonrpms.choon.net/centos/6/choonrpms-php-5.4/x86_64/php-devel-5.4.26-1.choon.centos6.x86_64.rpm

marked as duplicate by Michael Hampton Feb 13 '17 at 23:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    The remi and choonrpms repositories are not compatible with Amazon Linux. For that matter, there are almost no repos that are. – Michael Hampton Jan 2 '16 at 18:23
  • I agree with Michael. I've had very little luck with non Amazon repos. IMO having vetted repos for Amazon instance is worth the piece of mind. Have you checked the latest httpd version available on the latest AMI? – Hal Jan 2 '16 at 19:16
  • Actually, that post was a long time ago, I changed my perspective regarding my original goal. But thanks for the information. – Molkobain Jan 2 '16 at 22:29
0

Try installing php54-devel instead. I believe php-devel is the PHP 5.3 version in Amazon Linux, which has an Apache 2.2 dependency.

  • Same thing. At the beginning there is : Loaded plugins: priorities, security, update-motd, upgrade-helper 209 packages excluded due to repository priority protections Setting up Install Process Package php54-devel is obsoleted by php-devel, trying to install php-devel-5.4.31-1.el6.remi.x86_64 instead Resolving Dependencies And at the end, the same conflict errors. – Molkobain Aug 3 '14 at 9:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.