1

Tried kickstarting CENTOS 7 and got an unexpected message. The kickstart file has worked with 5 and 6 prior. Something has changed. Has anyone run into this?

Installation

 1) [x] Timezone settings                 2) [x] Installation source
        (America/Toronto timezone)               (http://centos.mirror.iweb.ca/7
 3) [!] Software selection                       /os/x86_64/)
        (Installation source not set up   4) [x] Install Destination
        )                                        (Custom partitioning selected)
 5) [x] Network settings
        (Wired (eth0) connected)

Kickstart

install
text
url --url http://centos.mirror.iweb.ca/7/os/x86_64/
lang en_US.UTF-8
keyboard us
network --device eth0 --bootproto dhcp --ipv6 xxxxx::10/64 --gateway xxxxx:1 --nameserver --hostname foo.example.com
rootpw xxxxxxxxxxxxx
firewall --disabled
authconfig --enableshadow --enablemd5
timezone America/Toronto
bootloader --location=mbr --append="rhgb quiet console=tty0 console=ttyS0,115200n8"
user --name=neil --password=xxxxxxxxxxxx
zerombr
clearpart --initlabel --all
part /boot --fstype ext4 --size=200 --ondisk=vda --asprimary
part pv.3 --size=100 --grow --ondisk=vda
volgroup vg01 pv.3
logvol / --fstype ext4 --name=lv01 --vgname=vg01 --size=3072 --grow
logvol swap --fstype swap --name=swaplv01 --vgname=vg01 --size=1024

%packages
--ignoremissing
vim*
tmux
openssl-devel
pcre-devel
make
gcc
fakeroot
%end

Found in the logs:

22:59:18,869 DEBUG packaging: adding yum repo anaconda with baseurl http://centos.mirror.iweb.ca/7/os/x86_64/ and mirrorlist None
22:59:19,036 ERR packaging: base repo (url/http://centos.mirror.iweb.ca/7/os/x86_64/) not valid -- removing it
4

I guess the error messages are caused by a typo: url --url http://centos.mirror.iweb.ca/7/os/x86_64/ should be url --url=http://centos.mirror.iweb.ca/7/os/x86_64/ By the way, I think you should add "@core" to the "%packages" section too; it includes a minimal set of very essential RPMs.

4

I believe you need to remove --device eth0 from the network command in the kickstart. Centos7 now uses some weird network device names (for example, on my vmware Centos7 VM it automatically detected the network device as Eno160, not eth0)

network --bootproto dhcp --ipv6 xxxxx::10/64 --gateway xxxxx:1 --nameserver --hostname foo.example.com
1

There are two things that can cause this problem:

  1. You specified a repository that doesn't exist or is invalid.
  2. Something is wrong with your package list.

I checked the repo and it appears correct.

However, your package list doesn't look right. Specifically:

%packages
--ignoremissing

This should appear on one line, i.e.:

%packages --ignoremissing
  • %packages --ignoremissing makes no difference. Indeed the error also happened without ignoremissing. – Neil H Watson Aug 2 '14 at 22:38
  • Better check the anaconda logs on the other virtual consoles to see if there's any useful information. – Michael Hampton Aug 2 '14 at 22:42
0

I have been struggling with this recently - not quite the same as you as I was using a local repository, but the same end result. Transpired that when extracting the ISO the files in repodata had their filenames truncated. Compare your repodate folder to (for example) http://mirror.ox.ac.uk/sites/mirror.centos.org/7/os/x86_64/repodata/

This info might help someone else who finds this page by googling the error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.