0

I followed a lot of solutions I found, but it still doesn't work. I can access the server by port 80 inside my network, bui I can't on another one, just by another port (like 62, as I set).


Files:

httpd.conf

Listen localhost:80
Listen *my_ip*:80
Listen *my_ip*:62

...

ServerName *a_free_DNS*:80

...

#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "C:/xampp/htdocs"
<Directory "C:/xampp/htdocs">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI 

    MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important.  Please see
    # http://httpd.apache.org/docs/2.4/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks Includes ExecCGI

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   AllowOverride FileInfo AuthConfig Limit
    #
    AllowOverride All

    #
    # Controls who can get stuff from this server.
    #
    Require all granted
</Directory>

httpd-vhosts.conf

<VirtualHost *:80>
    ServerName *a_free_DNS*
    DocumentRoot C:/xampp/htdocs/home/
</VirtualHost>

httpd-xampp.conf

#
# New XAMPP security concept
#
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
    #    Require local
    Order deny,allow
    Allow from localhost
    Allow from 192.168.0.*
    ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>

I put here just what I thought is important and what was modified.


I'm using an Arris router. I set as following:

Virtual Servers:

Description     Inbound Port    Type    Private IP Address      Local Port
Server          20-81           TCP     192.168.0.123           20-81

Port Triggers

I tried

Description     Outbound Port   Type    Inbound Port
Server          80-80           TCP     62-62

and

Description     Outbound Port   Type    Inbound Port
Server          62-62           TCP     80-80

and

Description     Outbound Port   Type    Inbound Port
Server          20-81           TCP     20-81

and any.

I tried disable the router's firewall too. What do I do?

closed as off-topic by EEAA Dec 15 '15 at 3:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions should demonstrate reasonable business information technology management practices. Questions that relate to unsupported hardware or software platforms or unmaintained environments may not be suitable for Server Fault - see the help center." – EEAA
If this question can be reworded to fit the rules in the help center, please edit the question.

0

Try using port forwarding, instead of port triggering. Your web server is not making an initial connection which is what you need for port triggering. Also start by setting everything to one port instead of a range.

  • The router settings have no port forwarding option, just port triggering. Anyway, you was right about set one port instead of a range, it's working!!! xD Thanks – Mateus Pires Aug 6 '14 at 4:20
  • Isn't working anymore, and I didn't change anything. ='[ – Mateus Pires Aug 6 '14 at 19:40
  • When I try to enter using the adress of the free DNS, the adress, at the adress bar of the browser, is changed to my.adress/cgi-bin/status_cgi – Mateus Pires Aug 6 '14 at 19:42
  • Try using only the virtual server, with one port and no port triggering. – Glen Aug 8 '14 at 0:36
  • Nothing... '__' – Mateus Pires Aug 10 '14 at 0:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.