2

I have booted my server, getting some GRUB error and I pasted the error below.

Error Code:-

GNU GRUB version 0.97(502k Lower/496556K upper memory)
[Minimal BASH-like line editing is supported.
For the first word, TAB lists possible command completions. Anywhere else TAB lists the possible completions of a device/filename]
grub>

Note : -

I have tried to recover the GRUB by following this step.

  1. GRUB is reinstalled on the master boot record:

  2. Boot the system from an installation boot medium.

  3. Type linux rescue at the installation boot prompt to enter the rescue environment.

  4. Type chroot /mnt/sysimage to mount the root partition.

  5. Type /sbin/grub-install /dev/hda to reinstall the GRUB boot loader, where /dev/hda is the boot partition.

  6. Reboot the system.

Again I am getting same error. How can I get the system to boot again?

  • 1
    What you see is the GRUB rescue shell. There should be other errors or indications of why your system was unable to boot. – Nathan C Aug 6 '14 at 12:10
  • Try typing linux / followed by a TAB to see if it is able to display any completions. – kasperd Aug 6 '14 at 12:23
  • I have tried follow method :- #find /grub/grub.conf – Nataraj raj Aug 6 '14 at 13:48
  • file is not found .. – Nataraj raj Aug 6 '14 at 13:49
  • grub > root (hd0,0) : filesystem type is ext2fs, partition type 0*83 – Nataraj raj Aug 6 '14 at 13:55
1

Your picture shows a GRUB install, which is apparently working correctly. However it has no menu configured, so you are left with just a command line.

Installing a suitable configuration is simplest to do from the operating system, that you will be booting with the GRUB install. This means you have to type in the commands manually the first time. This is quite doable, since GRUB has usable completion.

Usually you just need to type three commands at the GRUB prompt:

linux /path/to/kernel/image root=/path/to/root/device ro
initrd /path/to/initrd/image
boot

The images are likely to reside in (hd0,0)/boot or (hd0,0)/, but check (hd0,1)/ as well. The kernel image usually has a name starting with vmlinuz and the initrd starting with initrd, completion is your friend here.

  • Thank you for your reply.I will follow the same and update – Nataraj raj Aug 7 '14 at 10:06
  • I tried and got kernel panic error.please find the my screen shot. screencast.com/users/Raj13aug/folders/Grub%20Error/media/… – Nataraj raj Aug 7 '14 at 11:07
  • @Natarajraj Looks like you typed root=/dev/sde3 at the GRUB prompt. But you have no sde, perhaps you meant to type root=/dev/sda3. – kasperd Aug 7 '14 at 11:15
  • 1
    @Natarajraj What was the server doing prior to this happening? It looks like the server's trashed... – Nathan C Aug 11 '14 at 12:55
  • 1
    @NathanC It is not just /etc/passwd which is hosed. Before attempting to fix such a problem, it is useful to have an idea of which files might be hosed, and which can be relied on. The best way to get an idea is to know something about how the problem showed up in the first place. Could be the system newer worked in the first place, because the installer got interrupted half way through. But we haven't been told how it happened. – kasperd Aug 11 '14 at 13:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.