2

At work I need to use Red Hat Enterprise Linux (RHEL) version 5 on one particular server. I am experienced with Linux, but not much with RHEL (more with Debian and Ubuntu).

I want to install gitosis, but the EPEL package for gitosis depends on python-setuptools; and python-setuptools in turn depends on python-devel.

yum cannot find python-devel.

python-devel does not seem to exist in EPEL. This leads me to believe that it is probably supported in RHEL 5 directly; maybe EPEL isn't offering it because it's part of RHEL?

Checking with RPM search on pbone.net, I do find that Centos has a python-devel package, which again makes me think that python-devel ought to be provided by RHEL.

The yum.conf file on the server has a [main] entry with the line "distroverpkg=redhat-release" in it. The directory "yum.repos.d" has these repository files: epel.repo epel-testing.repo rhel-debuginfo.repo

Should python-devel be in the "redhat-release" repository? Is there some other official RHEL repository I should be including in my yum config?

Thanks for any help.


Additional information: Here is the output from the command yum repolist all:


# yum repolist all
Loaded plugins: rhnplugin, security
repo id                repo name                                  status
epel                   Extra Packages for Enterprise Linux 5 - i3 enabled: 3,423
epel-debuginfo         Extra Packages for Enterprise Linux 5 - i3 disabled
epel-source            Extra Packages for Enterprise Linux 5 - i3 disabled
epel-testing           Extra Packages for Enterprise Linux 5 - Te disabled
epel-testing-debuginfo Extra Packages for Enterprise Linux 5 - Te disabled
epel-testing-source    Extra Packages for Enterprise Linux 5 - Te disabled
rhel-debuginfo         Red Hat Enterprise Linux 5Client - i386 -  disabled
rhel-i386-client-5     Red Hat Enterprise Linux Desktop (v. 5 for enabled: 5,025
repolist: 8,448

It's interesting to me that this computer does not seem to have rhel-i386-server-5 as a repo. Is python-devel considered a server package? Can anyone tell me how to enable the server repo?

I looked for some setting to enable this, and all I could find was the file /etc/yum/pluginconf.d/rhnplugin.conf, which contains this:


[main]
enabled = 1
gpgcheck = 1

[rhel-i386-server-5]
enabled = 1

Editing to add additional information:


# yum install gitosis
Loaded plugins: rhnplugin, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gitosis.noarch 0:0.2-6.20080825git.el5 set to be updated
--> Processing Dependency: python-setuptools for package: gitosis
--> Running transaction check
---> Package python-setuptools.noarch 0:0.6c7-1.el5 set to be updated
--> Processing Dependency: python-devel for package: python-setuptools
--> Finished Dependency Resolution
python-setuptools-0.6c7-1.el5.noarch from epel has depsolving problems
  --> Missing Dependency: python-devel is needed by package python-setuptools-0.6c7-1.el5.noarch (epel)
Error: Missing Dependency: python-devel is needed by package python-setuptools-0.6c7-1.el5.noarch (epel)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Since it was requested, output of yum search python | grep -i devel:


# yum search python | grep -i devel
TurboGears.noarch : Back-to-front web development in Python
kobo.noarch : Python modules for tools development
nettle-devel.i386 : Development headers for a low-level cryptographic library
postgresql-python.i386 : Development module for Python code to access a
python-cherrypy.noarch : A pythonic, object-oriented web development framework
python-tools.i386 : A collection of development tools included with Python.
python-tunepimp.i386 : Python bindings for developing programs that will use
wxPython-devel.i386 : Development files for wxPython add-on modules

0

2 Answers 2

3

Okay, we contacted Red Hat Support and got an answer.

The python-devel package is in the RHEL Desktop Workstation sub-channel ("rhel-i386-client-workstation-5"), which was not enabled.

By default, the main channel ("core components", "rhel-i386-client-5") is enabled but no sub-channels. By using a web browser and logging in to your Red Hat Network account, you can pull up the record for your system and enable a sub-channel. This process is described in this KnowledgeBase page: http://kbase.redhat.com/faq/docs/DOC-11313

0

It seems that you have installed RHEL Desktop, not the Server edition. Repositories are included from RHN. Check the output from "yum repolist all" in my server:

rhel-x86_64-server-5 Red Hat Enterprise Linux (v. 5 for 64-bi enabled: 

However, the python-devel package must be included in the Desktop version. What are the results from:

yum search python | grep -i devel
3
  • I added the results to the main question, so I could format them as "code" and they wouldn't be all mushed together in this comment. Please see the question.
    – steveha
    Commented Sep 4, 2009 at 2:31
  • It seems that there is something wrong with the yum cache. Try "yum clean dbcache" and "yum clean metadata" to recreate the cache.
    – hdanniel
    Commented Sep 4, 2009 at 19:07
  • I had already tried "yum clean all" but I went ahead and tried "yum clean dbcache" and "yum clean metadata" as you requested. No change.
    – steveha
    Commented Sep 4, 2009 at 21:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .