1

I am running pfsense at home and I want to set up a PPTP vpn (yes I know its not secure, lets ignore that)

My current pfsense setup:

  • LAN: 192.168.1.1 (/24)
  • WAN PPPoE (real world IP lets say 123.123.123.123)

PPTP Settup:

  • Sevrer IP: 10.1.1.1
  • Sart IP: 10.1.1.2

Firewall Rules I clicked on PPTP VPN tab and also added a wildcard pass on that interface

When I try to connect to the VPN (from outside) I can connect and auth fine, I get this:

PPP adapter VPN HOME:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VPN HOME
   Physical Address. . . . . . . . . :
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 10.1.1.5(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.255
   Default Gateway . . . . . . . . . : 0.0.0.0
   DNS Servers . . . . . . . . . . . : 192.168.1.1
                                       8.8.8.8
   NetBIOS over Tcpip. . . . . . . . : Enabled

I can successfully PING 10.1.1.1 and 192.168.1.1 even all other machines in my LAN (192.168.1.0/24)

Thing is I can not seem to connect to the outter internet. How can I fix this?

  • Default Gateway . . . . . . . . . : 0.0.0.0 This should be your problem. You need to post the routing tables on your server and client. Also your making your life a little bit harder by giving 10.1.1.0/24 addresses to your PPTP network. You should reserve some IP addresses in the 192.168.1.0/24 network itself. – Louis Papaloizou Aug 7 '14 at 5:02
1

For internet access through the PPTP tunnel, make sure you put the ip of the pfsense as default gateway not the PPTP server ip.

Also make sure you set the option "Route all trafic over PPTP VPN" is set on your client.

Moreover, In the firewall options, there is a separate PPTP VPN tab at the top. Make sure, the PPTP VPN interface is selected and ipv4 and 6 and required TCP/UDP are allowed.

0

This is a known bug on amd64 versions of pfsense 2 and should be fixed in 2.2 (which unfortunately is not stable yet).

https://redmine.pfsense.org/issues/1107 https://forum.pfsense.org/index.php?topic=42113.15

...and as you already said yourself, you shouldn't use PPTP at all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.