I am being asked to resurrect a classic ASP application for temporary use. Wonderful. Well, the pay's the same, so I am now trying to get the thing to run on my localhost so I can test it and so on. I have copied all the files to c:\inetpub\wwwroot\ClassicASPapp. Using IIS 7.5 I set this folder as an Application I get handed a 503. Same result if I make it a Virtual Directory.

HTTP Error 503. The service is unavailable.

Note that there is a file in wwwroot called "iisstart.htm". If I double-click on the file from Windows Explorer, the browser displays the rendered HTML correctly. If I try to navigate to the file using:


I get the 503 then, too.

What is going on? Is there some global setting I need to change? Note that this is a new Windows 7 workstation.

I've checked and Classic ASP is definitely installed. The web site is associated with an application pool that has Classic ASP enabled, and 32-bit applications are also enabled.

Event Log:

Log Name:      System
Source:        Microsoft-Windows-WAS
Date:          8/8/2014 2:42:49 PM
Event ID:      5002
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      DESD71906.EClient.wa.lcl
Application pool 'DefaultAppPool' is being automatically disabled due to a series of failures in the process(es) serving that application pool.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Microsoft-Windows-WAS" Guid="{524B5D04-133C-4A62-8362-64E8EDB9CE40}" EventSourceName="WAS" />
    <EventID Qualifiers="49152">5002</EventID>
    <TimeCreated SystemTime="2014-08-08T21:42:49.000000000Z" />
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Security />
    <Data Name="AppPoolID">DefaultAppPool</Data>

It is true that the application pool gets stopped.

Test Connection / Authorization Detail:

The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that \$ has Read access to the physical path. Then test these settings again.

  • Did you see anything interesting in the Event Log? Whenever you see a 5XX error, there is usually some info logged. – Nitz Aug 8 '14 at 21:01
  • Well, @Nitz, I don't know if it's interesting, but I've added an entry I found in the Log. – Cyberherbalist Aug 8 '14 at 21:50
  • This event is a good clue. Look for events happening a tiny bit earlier indicating the "series of failures". My money is on the login - is it using an application pool with a specific user (not the default identity)? – Nitz Aug 8 '14 at 21:55
  • There is a series, but all of them say "The Windows Process Activation Service failed to create a worker process for the application pool 'DefaultAppPool'. The data field contains the error number." I don't see a "data field". – Cyberherbalist Aug 8 '14 at 22:15
  • Try looking for events in logs "Application" and "Security" – Nitz Aug 8 '14 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.